Jump to content

    
Sign in to follow this  
prst

TMS320F28335 - Проблема с SCI, каша в данных передача-прием

Recommended Posts

TMS320F28335 - Настраиваю переферию SCI. И какая-то странная проблема, причем которая проявляется независимо от инициализации.

 

Пробовал инициализацию от примеров которые указаны на сайте Texas Instruments, а также брал разные примеры в интернете(если верить они должны быть рабочими), более того даже с рабочего кода, всегда одно и тоже поведение.

 

Вот как все это проявляется — запаял провод с TX->RX(паралельно точно ни чего на линии нет), инициализировал фифо в режим на прием и на передачу 1 байта, но на приемной стороне ловится ловится ерунда. Настройка скорости в этом режиме по идее не влияет, но я все равно попробовал разные скорости, безрезультатно.

 

Прицепился осциллографом и увидел на экране кашу. Кака я уже говорил передавать должно 1 байт, но такое впечатление что передается весь фифо, причем его содержимое менятся от передачи к передаче... Среди этой каши стабильно видно первый правильный байт (0x05), а с 2го и по 16 каша-малаша.

 

GPIO вроде как выглядит что настроен правильно. Тактовая на переферию квлючена.

 

Что вообще ещё может быть, что приводит к такому проблемному проявлению?

 

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this