Jump to content

    

Ток утечки в затвор power MOSFETа

Использую ZETEX power P-channel MOSFET в определеной схеме, схема работает нормально пока не охлаждена (работает как рассчитана при комнатных и более высоких температурах)

Однако при охлаждении наступает сбой и похоже на то что появляется значительная утечка через затвор (примерно в районе 10-25uA), данный ток достаточен для сбоя работы схемы (разряжает конденсатор который сидит на затворе и который должен держать заряд)

В схеме нет других очевидных путей разряда данного конденсатора поэтому похоже на затвор, как-бы странно оно не звучало. Эффект проявляется только при низких темпераурах (начинает проявлятчся даже при примерно 0 градусов C, но ярко выражен при охлаждении до -20 - -40).

Datasheet трансистора ничего не говорит об температурной зависимости тока утечки гейта, максимальный ток утечки в таблице 100nA (хотя я бы ожидал его на порядок еще ниже)

Может кто-либо встречался с таким эффектом ?

Share this post


Link to post
Share on other sites

Ну, помимо цепи разряда, есть же и цепь заряда конденсатора, там утечки более вероятны. От чего он заряжается-то?

И питание от схемы отключается ли? Что с утечками при выключении питания, может, там защитные диоды приоткрываются?

Короче, схему стоит выложить.

Share this post


Link to post
Share on other sites
Ну, помимо цепи разряда, есть же и цепь заряда конденсатора, там утечки более вероятны. От чего он заряжается-то?

И питание от схемы отключается ли? Что с утечками при выключении питания, может, там защитные диоды приоткрываются?

Короче, схему стоит выложить.

Спасибо за ответ

Нет, питание не отключается, цепь заряда не изменяется и находится постоянно под напряжением (конденсатор находится между D и G, керамический X7R, заряжается со стороны гейта от напряжения 6V через два последовательных резистора 47к и 100к). На осцилографе, при охлаждении, вижу появление тока от нескольких uA до 20-25uA на резисторax в направлении гейта (а не от него, как будто кто-то крадет потенциал с конденсатора/гейта), по схеме в этой точке - только сам конденсатор соединен с гейтом и серийный резистор. Не вижу другого пути разряда как в затвор что более чем странно...При комнатной или выше температуре - все нормально, потенциал держится как полагается...

Share this post


Link to post
Share on other sites

А вот взять отдельный транзистор без всяких дополнительных деталей?

Этому никто не поверит... Если только корпус не сделан из высокотемпературного сверхпроводника....

Share this post


Link to post
Share on other sites

Может роса выпала на плате?

А вообще без схемы гадать не интересно. Гейт какойто, кто у кого что крадет? Или это только мне одному не понятно

Share this post


Link to post
Share on other sites

Хорошо бы знать название транзистора и напряжения на его выводах. (а еще лучше полное описание схемы)

Может внутри транзистора стоит защитный стабилитрон, у которого с уменьшением температуры уменьшается порог срабатывания и соответственно растет ток.

Share this post


Link to post
Share on other sites
Может роса выпала на плате?

Какая роса при -40 градусах... Это нужно очень много соли добавить...

Share this post


Link to post
Share on other sites
цепь заряда не изменяется и находится постоянно под напряжением (конденсатор находится между D и G, керамический X7R, заряжается со стороны гейта от напряжения 6V через два последовательных резистора 47к и 100к).

А керамика вне подозрений? Кроме того, что у X7R ТКЕ и dC/dU совсем не нулевые, так многослойные ещё и механически нежные.

Share this post


Link to post
Share on other sites

Пока есть проблема выложить схему, но есть ощущение что есть намек...

Я охлаждаю одним из видов спрея для охлаждения электроники, сегодня попался другой балончик под руку, полупустой но фирмы производителя которым пользовался уже когда-то в прошлом..а тот с чем работаю сейчас - другой.

Взял кусок изолятора, приклеил к столу, воткнул в него пробы DVM флюковского на замер сопротивления, расстояние между пробами - несколько миллиметров.

Прибор показал сопротивление "бесконечное" (выше 50 мега), затем заспреил это место из баллончика - сопротивление начало на глазах падать до 3-4 мега...и затем, минуты через3-4 начало обратно расти...

Это мне не понравилось...начал охлажлать схему спреями из этих разных балончиков...и в результате - при охлаждении из одного - проблема всплывает четко...при охлажлении другим - все ок, работает как положено...

Вот и раз...видимо состав газа в том балоне с которым работал эти дни - проблемный, создает определенную, невысокую но проводимость достаточную для сбоя схемы...

Завтра куплю еще того что не создает проблемы, буду еще гонять...

Share this post


Link to post
Share on other sites
Пока есть проблема выложить схему, но есть ощущение что есть намек...

Я охлаждаю одним из видов спрея для охлаждения электроники,

Это мне не понравилось...начал охлажлать схему спреями из этих разных балончиков...и в результате - при охлаждении из одного - проблема всплывает четко...при охлажлении другим - все ок, работает как положено...

..

Некорректно был задан вопрос про утечки при минусе, подумал - раз свой, то провел испытания при реальном минусе, вот и проваландалисть. Был бы ТС рядом - обложил бы матом. А еще свой, понимаешь. Больше посты от Саша Z не читаю.

Share this post


Link to post
Share on other sites
Некорректно был задан вопрос про утечки при минусе, подумал - раз свой, то провел испытания при реальном минусе, вот и проваландалисть. Был бы ТС рядом - обложил бы матом. А еще свой, понимаешь. Больше посты от Саша Z не читаю.

 

Просьба если нет ничего конкретного сказать - проходить мимо а не считать своим долгом лишь бы да чего ляпнуть в ветку...и матом обкладывать - своих друзей

 

По делу...испытания при контролируемом минусе проводились для полной системы, в термо камере, но не все режимы проверялись ибо конкретный борд - в стадии разработки, на то время не все его режимы работали. Данная проблема проявляется при включении определенного режима работы системы когда борд задействует ту часть схемы о которй речь, до этого эта функциональность еще не работала. При охлаждении в камере до 0 град. проявилась проблема, дальше нет смысла охлаждать в камере, прекратил и занялся этим бортом отдельно, на столе, охлаждая конкретные участки на которые может пасть подозрение судя по поведению схемы, так и вышел на проблемность блока о котором говорю.

 

А керамика вне подозрений? Кроме того, что у X7R ТКЕ и dC/dU совсем не нулевые, так многослойные ещё и механически нежные.

 

Насчет конденсатора - проверил, была вероятность что по ошибке поставил Y5V (которые вообще проблемны при температурах, их графики...), заменил на X7R, не помогло

 

Share this post


Link to post
Share on other sites

Плату надо лаком покрывать.

Максимально возможное содержание водяного пара в воздухе резко падает со снижением температуры. Когда на минус камера пойдет влага из воздуха выпадет в виде росы и замерзнет в иней, потом при переходе на плюс оно растает и испарится.

Запихивать незащищенную плату в камеру нет смысла, получите глюков с гарантией, причем не только в высокоомных цепях.

А если еще и отмыли плату плохо после монтажа то спектр глюков расширится еще сильнее.

Share this post


Link to post
Share on other sites
Плату надо лаком покрывать.

Максимально возможное содержание водяного пара в воздухе резко падает со снижением температуры. Когда на минус камера пойдет влага из воздуха выпадет в виде росы и замерзнет в иней, потом при переходе на плюс оно растает и испарится.

Запихивать незащищенную плату в камеру нет смысла, получите глюков с гарантией, причем не только в высокоомных цепях.

А если еще и отмыли плату плохо после монтажа то спектр глюков расширится еще сильнее.

 

Да, резонно, хотя в конечном устройстве платы внутри, а устройство герметизированно и прокачено CO2. Но проверки делал в камере с устройством не прокаченным газом, т.е. внутри был воздух. Хотя, исходя и прошлого опыта, данная роса - дистилиррованная вода (если плата чистая, согласен), и не должна по идее мешать...

На столе, на открытых бортах, спреил на непокрытые борты охлаждая участки очень серьезно (видимо иногда и ниже допустимыьх пределов в -40), капала вода, но работало без проблем (кроме того проблемного блока).

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this