Jump to content

    
Sign in to follow this  
ScorPio

Stratix 2 не стартует на минусе..

Recommended Posts

ScorPioСлучайно предохранителей нет всхеме?

У нас была фишка на минусе и плюсе предохранитель начинал чудить.

 

И проверте токи ваши dc-dc выдерживают?

Нет, даже перемычек между DC/DC и остальной схемой нет - плейн подключается прямо к ножке DC/DC, вставленной в отверстие.. DC/DC с запасом - с другими прошивками модуль жрёт раза в полтора больше и на плюсе всё работает..

Share this post


Link to post
Share on other sites

Насчет того, что по мере прогрева ПЛИС стартует: как это происходит?

Питание включается, старта нет, далее простое ожидание на поданном питании, никто ничего не трогает и через N минут включение; или по мере прогрева делается вкл/выкл, ресет и т.п., пока на очередном цикле не включится?

Share this post


Link to post
Share on other sites
Насчет того, что по мере прогрева ПЛИС стартует: как это происходит?

Питание включается, старта нет, далее простое ожидание на поданном питании, никто ничего не трогает и через N минут включение; или по мере прогрева делается вкл/выкл, ресет и т.п., пока на очередном цикле не включится?

1. Помещаем модуль в термокамеру, подключаем всё необходимое (но питание не подаём), устанавливаем -40 и ждём пока всё остынет и надежно промерзнет.

2. Подаем питание. Видим подозрительно низкое потребление. Убеждаемся, что по JTAGу тишина.

3. "Залазим" в камеру, оперативно проверяем все напряжения (убеждаемся, что они прекрасны).

4. Выключаем питание, перетыкаем JTAG в соседний третий стратикс, питание включаем - убеждаемся в работоспособности JTAGa и также через выключения питания возвращаемся ко второму. Убеждаемся в отсутвии изменений - JTAG ничего не видит.

5. Не выключая напряжения питания:

5.1) Просто ждём минут 10-15, периодически включая-выключая или просто оставляя включенным - ничего не меняется.

5.2) Не выключая питания меняем установку камеры на +. Показания датчика в камере начинают рости и в какой-то момент потребляемый ток прыгает. Контрольный тест по JTAGу показывает, что ПЛИС ожила..

 

В общем, подняли питание банков 3,4,7,8 с 1.8 до 1.86 (допуск - до 1.89) - работает. Текущая гипотеза - где-то на плате (переходных?) при морозе теряется (измеряем рядом с DC\DC).. По мне - притянуто за уши, но в это больше верится, чем в перемаркированные\полубракованные микросхемы..

Share this post


Link to post
Share on other sites

Проверять напряжения, "залезая" в камеру, конечно, не особо удобно.

 

По поводу повышения напряжения питания - соответствует ли "подозрительно низкое потребление" обычному потреблению платы с незапрограммированной ПЛИС? Все ли хорошо с VCCPD?

Если в ПЛИС есть ненагруженные пины с внутренним pullup, реальное питание соответствующего банка косвенно можно измерить на них, сравнив показания в нормальных условиях и на холоде.

В общем, повышение питания IO с 1,8 до 1,86, с учетом того, что ваша ПЛИС должна работать и при 1,5В IO, выглядит неуютным решением.

Share this post


Link to post
Share on other sites
3. "Залазим" в камеру, оперативно проверяем все напряжения (убеждаемся, что они прекрасны).

Это не спортивно, что мешает вытянуть провода из камеры?

Аналогично с JTAG.Так результаты будут точнее.

 

 

Текущая гипотеза - где-то на плате (переходных?) при морозе теряется (измеряем рядом с DC\DC).. По мне - притянуто за уши, но в это больше верится, чем в перемаркированные\полубракованные микросхемы..

Надо измерять радом с ПЛИС.

Share this post


Link to post
Share on other sites

ИМХО перемаркированная ревизия (кстати смотрели эрату ?) плис в брак.

 

Тут давеча под видом новых сыклонов 3 нам продали старые сыклоны 3 древней ревизии. Так вот, они не грузятся (в принципе не грузятся) если в проекте используется больше определенного процента блочков памяти (те которые М4К). Лечиться это ключиком в ква, но при этом времянка памяти проседает процентов на 20 и проект не укладывается во времянки. Так что ....

Share this post


Link to post
Share on other sites

Перемаркировку, конечно, нельзя исключить, однако я не представляю, из чего их должны были перемаркировать, чтобы добиться блокирующей неработоспособности на -10 и -20 градусов. Обычно коммерческие грейды (которые 0 - +70) при такой температуре живут прекрасно. Разве что какой-то уж очень специальный брак. В проблему схематики или платы верится гораздо легче.

Share this post


Link to post
Share on other sites
однако я не представляю, из чего их должны были перемаркировать, чтобы добиться блокирующей неработоспособности на -10 и -20 градусов.

какие нить образцы из установочной партии, пролежали на складе лет 5, а тут видят партия чипов идет и решили ее разбавить этими чипами, накатав новую маркировку %) те сыклоны были 2008 года выпуска, где то лежали 4 года %)

Share this post


Link to post
Share on other sites

Конечно, в перемаркировку как явление я верю, и даже приходилось с этим сталкиваться - чем старше и дороже чип, тем больше шансов нарваться на предприимчивых китайцев. ПЛИСки с их дикой разницей в цене между медленной коммерцией и быстрыми индастриалами, конечно, лакомый кусок для перемаркировки. Даже странно, что для таких дорогих компонентов разработчики не предусмотрели внесение копии маркировки в OTP.

 

Однако, неработоспособность именно ПЛИС на легком морозе не встречалась ни разу. На морозе чаще любят подглючивать аналоговые вещи, дурят конденсаторы в источниках питания, уплывают референсные напряжения в DC/DC и т.п.

Share this post


Link to post
Share on other sites

У нас была партия из 100 штук EPM7128 брак не прошивались 8 из 10, процессоры ADSP2101 не работали так что цифра тоже бывает с душком. Теперь работаем только с официальными представителями.

Share this post


Link to post
Share on other sites

По моему опыту, скорее всего плохо пропаяно бга. На минусе у вас непропаянные шарики перестают контачить, происходит недозапитка схемы, и отваливается тот же житаг. Обычно диагностика выглядит так: если житаг не отваливается и питания хватает, гоняется тест boundary scan. Если видим что на минусе отваливаются i/o - микросхему на перепайку.

Есть и другой вариант, что у микросхему не срабатывает POR. На это косвенно указывает работа на повышенном напряжении. Диагностика - посмотрите, пытается ли микросхема считать содержимое флеши при включении на минусе. Или, замораживайте загруженную альтеру (под питанием т.е.), но градусов на 10 ниже.

 

А вообще, Сергей, заходите, если что. В соседний отдел)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this