Jump to content

    
Sign in to follow this  
vts

Неправильное представление Nets в Constraint Manager

Recommended Posts

Использую элемент представляющий массив из 384-х контактных площадок. В качестве выводов использую шину A<384..1>. В схеме к элеиенту подключил шину a<384..1>, но в Constraint Manager везде присутствует шина А(383), начинающаяся с контакта 2. При этом появилось соединение с названием ONE, которого нет в схеме. Если двойным щелчком выделить это соединение, то подсвечивается сразу несколько цепей, начинающихся с 1 (1, 10, 11,100, 110,...). Другие соединения шины отображаются правильно. Подскажите где ошибся.

Share this post


Link to post
Share on other sites

Переименовал все цепи, начинающиеся с 1 в а1, а10 и т.д. и вопрос с подсвечиванием снялся, но теперь в Constraint Manager существуют и цепи а1,а10... и 1,10,11... Переименовал в b1, b10... и количество цепей еще увеличилось, хотя на схеме их не существует. Как удалить несуществующие цепи из СМ?

Share this post


Link to post
Share on other sites

у меня на схеме имеется шина bus<100..1>. Но, подключено к ней только 49 ответвлений. соответственно, шина избыточная. И в СМ поэтому моя шина обозначается не как bus<100>, а bus<49>. остальные "несуществующие" обозначаются в СМ как bus<50>,bus<51>... Возможно, стоит попробовать избыточность шины, думаю, это не испортит общей картины.

Share this post


Link to post
Share on other sites
В этом случае Concept ругается на различие в ширине шины и рзрядности вывода элемента

да, ругается, только когда шина меньше, чем номер вывода. если шина <100> то вывод должен быть меньше ста (насчет равно, не знаю)

Share this post


Link to post
Share on other sites

У элемента вывод А<384..1> подключаю шину а<384..1>все нормально, меняю на а<400..1> - ругается. Переименовал шину в b<384..1>, а в СМ она все равно числится как шина А.

Share this post


Link to post
Share on other sites

разве вывод элемента не должен обозначаться как А<384>? я вообще использую bus tap. А вы, скорее всего, просто переименовываете линии вручную. тогда шина должна обозначаться А<384..1> (а лучше А<400..1> ) а сигнал от вывода элемента должен быть А<384>. уверены, что "А" латинская?

Share this post


Link to post
Share on other sites

С помощью упаковочных утилит сгенерил лист соединений - там все правильно , лишний цепей нет, а в СМ они присутствуют.

post-54915-1337851221_thumb.jpg

Share this post


Link to post
Share on other sites

странно, как будто двоичный код...

а зачем к bus tap-ам присоединены оборванные связи с именами? я думаю, что тапы нужны, чтобы непосредственно вывод подключать к шине. если вывод к шине непосредственно не подключать, можно обойтись названием связи.

на рисунке слева разъем подключен к шине через баз тап непосредственно, а резистор справа подключен к той же шине и той же первой связи в шине, но без баз тап через прееименовывание.

post-62953-1337851756_thumb.jpg

Share this post


Link to post
Share on other sites

Переделал по Вашему варианту. Но от этого размерность шины только увеличилась в два раза. СМ почему-то не удаляет старые имена соединений и плюсует к ним новые. Интересно откуда он берет эту информацию и как можно обнулить ее.

 

 

 

Удалил все старые файлы из папок дизайна и все стало нормально.

post-54915-1337857375_thumb.jpg

Edited by vts

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this