Jump to content

    
Sign in to follow this  
JeDay

LPC1778. Глюк с SPI1.

Recommended Posts

Всем добрый день.

Натолкнулся на дефект в данном камне. Плата SK-MLPC1788. SPI1 работает на всех ногах в частности на 4-м порту как на плате, но на 0-м порту не работает. Такого дефекта в еррате нет.

Кто нибуть сталкивался данной проблемой?

Share this post


Link to post
Share on other sites

Мы тоже работаем с SK-MLPC1788 и тоже столккнулись с подобной проблемой.

Но, во-первых:

На SK-MLPC1788 установлен LPC1788, а не LPC1778.

во-вторых:

На порту P0 для SSP1 мы использовали только P0.12 (MISO1) и P0.13 (MOSI1). И проблема была только с ногой P0.12 - она не работала, после перенесли MISO1 на P1.18 - всё заработало. А нога P0.13 работает нормально.

 

Но рабочее устройство у нас должно быть на LPC1788 и есть опасения, что на нём будут такие же проблемы.

Можете указать какие именно ноги у вас не работали на P0 с SSP1?

Share this post


Link to post
Share on other sites

P0.8(MISO1) не работает, P0.7 и P0.9 работают нормально. Остальные варианты не пробовал.

У нас уже чистовая плата пришла, пришлось програмный SPI городить. Благо на нем только термодатчик подцеплен, 2 байта данных можно и ногодрыганьем считать...

 

Share this post


Link to post
Share on other sites
P0.8(MISO1) не работает, P0.7 и P0.9 работают нормально. Остальные варианты не пробовал.

У нас уже чистовая плата пришла, пришлось програмный SPI городить. Благо на нем только термодатчик подцеплен, 2 байта данных можно и ногодрыганьем считать...

Ещё раз повторю вопрос - на каком именно процессоре у Вас баг - на LPC1778 (как указано в топике) или на LPC1788 (SK-MLPC1788) ?

Какой из них стоит в Вашем рабочем устройстве? И в каком корпусе?

Пожалуйста ответьте - очень интересует этот вопрос, так как планируем использовать в рабочем устройстве LPC1778, но пока имеем только отладку с LPC1788.

Т.е. - это баг конкретно LPC1788 или всего семейства LPC177x/178x ?

Share this post


Link to post
Share on other sites

Похоже и я натолкнулся на проблему из этой же серии (чип LPC1778 208 ног BGA). Прокинулся с подключением к SPI1. При программной реализации (P0.7 - SCK, P0.9 - MISO, P0.10 - MOSI) P0.9 на прием не работал..

 

PS: "...бит 7 регистра IOCON надо ставить == 1." - действительно... Спасибо!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this