Jump to content

    

Вопросы по Agilent ADS

Помните, я Вам писал, что в первом проекте порт вроде есть, но его как бы нет. Вы правильно ставили SMD-порты, в горизантальной плоскости. Сделайте тоже самое для non-портов, только в вертикальной плоскости. Два порта в одном. Верхняя и нижняя точки должны упираться в металл.

 

Спасибо большое. С None-портами все работает, но не более двух слоев, дальше реалистичность чуть страдает, но это дело техники...

Я кстати заметил что у меня некоторые примеры не работают. В частности пример \\Agilent\ADS2011_10\examples\Momentum\RF\RFBoard_wrk.7zap.

У меня ADS 2011.10. (7zads не поддерживает, хоть убей или я тупой). Причем я могу поставить TML порты только 2 штука (Input\Output). Если ставлю все TML, то пишет (The port setup needed to be corrected: Calibration will not be used for port "P15" (pin "P15" is not on the edge between a conductive and a nonconductive region), +выскакивает окно с ошибкой (Analysis "Solve" (M131031160913) of design R_23_lib:R_23_4:layout failed). Такие же ошибки выскакивают в примере RFBoard_wrk.7zap, что меня очень огорчает. Это же примеры - они должны работать!

Пробовал переустанавливать ADS, пробовал на другом компе... ничего.

Может быть это система? Или версия ADS?

 

Даже те примеры, где все работает, при вставке моего куска платы в проект все летит. Может даже это из-за скругленных углов моей платы, или еще что-то?

Дайте знать если у кого-то тоже было такое...

 

Via_structure_v2 тоже ругается на подложку, причем я там даже ничего не менял, просто посмотрел сначала. При смене подложки возникают соответствующие ошибки (см. выше)

Edited by estel23

Share this post


Link to post
Share on other sites
Спасибо большое. С None-портами все работает, но не более двух слоев, дальше реалистичность чуть страдает, но это дело техники...

Я кстати заметил что у меня некоторые примеры не работают. В частности пример \\Agilent\ADS2011_10\examples\Momentum\RF\RFBoard_wrk.7zap.

У меня ADS 2011.10. (7zads не поддерживает, хоть убей или я тупой). Причем я могу поставить TML порты только 2 штука (Input\Output). Если ставлю все TML, то пишет (The port setup needed to be corrected: Calibration will not be used for port "P15" (pin "P15" is not on the edge between a conductive and a nonconductive region), +выскакивает окно с ошибкой (Analysis "Solve" (M131031160913) of design R_23_lib:R_23_4:layout failed). Такие же ошибки выскакивают в примере RFBoard_wrk.7zap, что меня очень огорчает. Это же примеры - они должны работать!

Пробовал переустанавливать ADS, пробовал на другом компе... ничего.

Может быть это система? Или версия ADS?

 

Даже те примеры, где все работает, при вставке моего куска платы в проект все летит. Может даже это из-за скругленных углов моей платы, или еще что-то?

Дайте знать если у кого-то тоже было такое...

 

Via_structure_v2 тоже ругается на подложку, причем я там даже ничего не менял, просто посмотрел сначала. При смене подложки возникают соответствующие ошибки (см. выше)

 

На NON-порты есть некоторые ЕМ ограничения. Прикладываю еще один хелп, где все расписано более подробно, в том числе для NON-портов. TML - более универсальный порт. Программа автоматически проверяет подключение порта, и, при необходимости, преобразует TML в TML(0) или NON. Это преобразование сопровождается выводом сообщения. Это не ошибка - это программа работает за нас! Например, если Вы поставите TML-порт в середину площадки для чип-элемента, то он будет автоматически преобразован в NON. Если поставите TML-порт на грань этой площадки, но рядом с этой гранью будет, напрмер, корпусной полигон или другой проводник, и для этого порта будет недостаточно места для размещения виртуальной transmission line с генератором сигнала, то этот порт будет преобразован в TML(0).

В 11 версии были баги, которые устранены в более стабильной 12. Выпускались обновления. Для 12 версии официально 4, а неофициально видал упоминание даже про 7-ое.

Прикладываю обычный zip-архив Via_structure, правда в 13_06.

Via_structure тоже из примеров. Запустил пример RFBoard: кроме сообщений о преобразовании портов - ничего, что-то считает. Прилагаю тоже архив без результатов симуляции.

 

Electromagnetic.rar

via_structure_wrk.zip

RFBoard_wrk.zip

Share this post


Link to post
Share on other sites
13_06 не устанавливается почемуто ... ?

 

Проверьте это:

 

Manual Uninstallation

 

To uninstall ADS manually:

This method should only be used if there are any issues while uninstalling using ADS uninstaller.

 

Delete the product installation directory(for example, C:\agilent\ADS2011_05.)

Delete the Start menu items.

To delete the registry entries, choose "Start > Run" and then type: regedit to open the Registry Editor. Search all instances of ADS and remove the same from registry editor. It can be in any of the following two forms:

Platform Location

32-bit Windows My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Agilent\ADS\<release version>. For release version, see Registry Version Table.

64-bit Windows My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432NodAgilent\ADS\<release version>

Delete the file .com.zerog.registry.xml in the C:\Program Files\Zero G Registry directory.

Note

Zero G Registry is a hidden directory, therefore, you may have to adjust your Windows Explorer settings in order to view directory.

Share this post


Link to post
Share on other sites
не помогло, ...

 

А что система пишет?

 

Попробуйте:

остановить службу менеджера лицензий,

запустить killlmgrd.exe из c:\Agilent\EEsof_License_Tools\bin\,

удалить всю папку Zero G Registry,

 

Share this post


Link to post
Share on other sites

Здравствуйте. У меня такая ситуация. Есть плата, три слоя. Проводящие 1 и 3 соединяются отверстием (Via). Как правильно задать средний слой, чтобы он был GND?

Пробовал портами: минусы (GND!) схемы ставил на средний слой, не помогло.

Share this post


Link to post
Share on other sites
Здравствуйте. У меня такая ситуация. Есть плата, три слоя. Проводящие 1 и 3 соединяются отверстием (Via). Как правильно задать средний слой, чтобы он был GND?

Пробовал портами: минусы (GND!) схемы ставил на средний слой, не помогло.

 

Должно работать:

bff5b0f0f8353afd445048bf28b71097.jpeg fce20cc47d5ebe7279bbe893e54a3479.jpeg 531c39e5e19673e537a4d61550b68c9d.jpeg 7e900f39e74e4c43084896d95dbf3ddf.jpeg a3a04628922110fa164d70c2f299aaa7.jpeg

Share this post


Link to post
Share on other sites

В теме Питание VCO и фазовые шумы была ссылка на статью, в которой рассматривалось измерение фазового шума:

Как вы думаете, Microwave Journal достаточно авторитетен в таких вопросах? Ну тогда http://www.holzworth.com/Aux_docs/PhaseNoi...e_MWJ_Jun08.pdf Именно аудиокарта и FFT на компе. Зато вопросы калибровки разобранны достаточно глубоко.

Пытаюсь в ADS промоделировать работу схемы, представленную в статье на рис. 3, с помощью идеальных элементов:

post-53413-1385134669_thumb.png.

Если я правильно понял смысл, исключение фазового шума источника сигнала происходит за счет подачи на смеситель сигнала в квадратуре. При этом на выходе ПЧ смесителя наблюдаем постоянную составляющую, которая пропорциональная уровню фазового шума. На первом шаге без усилителя и аттенюатора добиваемся нулевого выходного напряжения смесителя (он же фазовый детектор). Далее поворачиваем фазу на известный угол, я повернул ее на 5 градусов. Рассчитываем калибровочный коэффициент в дБ как отношение выходного напряжения к углу поворота в радианах. После снова возвращаем нуль на выходе смесителя и в плечо по РЧ смесителя ставим аттенюатор и усилитель так, чтобы мощности на входах смесителя не изменились. При этом, как я понял, на выходе смесителя сигнал изменится.

Я, видимо, что-то делаю не так - ни размах, ни смещения относительно нуля на выходе смесителя не произошло. Подключил контроллер шума, проверил, что фазовый шум меняется до подключения усилителя, и после. Но хотелось бы понять, как правильно построить схему, чтобы выход фазового детектора изменялся.

 

Share this post


Link to post
Share on other sites

Вопрос по портам в Моментуме.

Если я моделирую индуктор например в Кэденсе разведенный, то мне нужно просимулировать эффект возвратных токов через субстрат и кольцо что вызывает снижение добротности на высоких частотах.

 

Вот я прикрепил картинку примерную моeй разводки которая в Моментум экспортируется для симуляции.

желтым цветом отмечены Вии от проводящего кольца к субстрату.

Порты объявляю так:

PORT1:

p1 pin, Positive reference - p1r pin

 

PORT2:

p2 pin, Positive reference - p2r pin

 

Это правильно в Моментуме p1r и p2r объявлять как Positive reference?

 

дело в том что когда пины: p1r,p2r объявлял как негативный референс то на графиках полная ерунда получалась но, а когда вообще без никакого референса то показывалась очень высокая добротность, и значение индуктивности не падало даже на очень высоких частотах т.к. возвратные токи не проходили через кольцо, т.е. референс по умолчанию был идеальной землей что естесственно действительности не соответствует.

post-38121-1385375127_thumb.png

Share this post


Link to post
Share on other sites

короче это было не правильно референс пин делать позитивным. Надо было делать его негативным конечноже, а не работало потому что во время экспорта ячейки из Виртуозо в Моментум почемуто не экспортировались Вии и соединение с землей было прервано. Добавил в ручную в ячейке Моментума Вии, и поставил порт референс негативным и все заработало.

(кстати в данной конфигурации весь ток не будет через субстрат течь, для этого нужна другая конфигурация где как по умолчанию референс портом подразумевается земля под субстратом а не те точки отмеченные на рисунке)

Share this post


Link to post
Share on other sites

Добрый день! Помогите разобраться с экспортом файлов из ADS: создал n-портовую схему и ее S параметры надо экспортировать в Snp (Znp) файл.

Share this post


Link to post
Share on other sites
Stefan1

Добрый день! Помогите разобраться с экспортом файлов из ADS: создал n-портовую схему и ее S параметры надо экспортировать в Snp (Znp) файл.

Нужно нажать на иконку с дискетой и стрелкой. Дальше там всё понятно мне кажется.

 

post-55996-1386843242_thumb.jpg

Edited by 1lliivv1

Share this post


Link to post
Share on other sites
Нужно нажать на иконку с дискетой и стрелкой. Дальше там всё понятно мне кажется.

Благодарю за помощь!

Share this post


Link to post
Share on other sites

Подскажите туториал для для реализации, делителя на полосках. Нужно нарисовать делитель, и проверить его ачх. Есть ли туториалы или примеры как нарисовать схему и плату прямо в адс и проверить?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now