Jump to content

    
Sign in to follow this  
toweroff

Keil 4.50

Recommended Posts

В списке шрифтов киррилического нет. Редактор русские буквы отображает, но сам их написать не может

 

 

Скачайте и установите в Windows шрифт Courier New Cyr, после чего он появится в списке ...

Share this post


Link to post
Share on other sites
Скачайте и установите в Windows шрифт Courier New Cyr, после чего он появится в списке ...

шрифт ОТОБРАЖАЕТ русские буквы, если они изначально присутствуют

а вот ВВЕСТИ их в редакторе - нихт орбайтн

кстати, даже после добавления шрифт в ворде видится, а кейлом не показывается в списке

Share this post


Link to post
Share on other sites
шрифт ОТОБРАЖАЕТ русские буквы, если они изначально присутствуют

а вот ВВЕСТИ их в редакторе - нихт орбайтн

кстати, даже после добавления шрифт в ворде видится, а кейлом не показывается в списке

Это видно новая фишка :) по сравнению с 4.23 Менюшка Colors&Fonts очень бедная.

P.S. Тут (4.50) добавили general editor settings (вкладка Editor), а именно выбор Encoding : видимо отсюда растут ноги.

Share this post


Link to post
Share on other sites
P.S. Тут (4.50) добавили general editor settings (вкладка Editor), а именно выбор Encoding : видимо отсюда растут ноги.

и юля? ansi, utf, китайцы, корейцы и японцы

пробовал на всех - вид в профиль, вместо щелочки - дырочка :biggrin:

Share this post


Link to post
Share on other sites

Я вообще сижу на 4.21, поскольку в версиях 4.22 и 4.23 появились новые ошибки, которые мне мешают. Правда, я не использую Си и пишу только на ассемблере и Аде, а Кейл применяю в первую очередь как отладчик. Про ошибку с русским в 4.50 им в багрепорт запостил, но пока реакции нет.

Share this post


Link to post
Share on other sites

Были и в прошлых версиях проблемы с русским языком. Можно было решить одним из способов -

- сначала выбрать шрифт с русским буквами, потом выбрать тот, что надо

- изменить в ключе реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage значение «1252» на «1251».

Но в данном случае не проходит.

Share this post


Link to post
Share on other sites
Я вообще сижу на 4.21,

 

Я тоже раньше сидел на нем, но он не поддерживает М4.

 

поскольку в версиях 4.22 и 4.23 появились новые ошибки, которые мне мешают.

 

Какие? Асм не интересует принципиально.

Share this post


Link to post
Share on other sites

Что-то с отладкой. Что именно, не помню, просто то, что нормально отлаживалось в 4.21, стало вызывать проблемы в 4.22, а в 4.23 не исправили. Вероятно, для Вас это роли не играет, поскольку отладка у меня на уровне именно ассемблера.

Share this post


Link to post
Share on other sites
Что-то с отладкой. Что именно, не помню, просто то, что нормально отлаживалось в 4.21, стало вызывать проблемы в 4.22, а в 4.23 не исправили. Вероятно, для Вас это роли не играет, поскольку отладка у меня на уровне именно ассемблера.

 

Да вроде пока проблем с отладкой на уровне ассемблера проблем не замечал. во всяком случае с пошаговым выполнением.

Сами программы были естественно на си, с написанием программ на ассемблерах я уже лет 15 как завязал.

Share this post


Link to post
Share on other sites

Подскажите компилируются ли у Вас в 4.50 проекты с RL??

В 4.23а появился emWin, но с текущим лекарством проекты с emWin у меня не компилятся. В 4.50 внесли RL в дистрибутив кейла и теперь в новой версии у меня перестали компилиться проекты с RL (ошибка лицензии)!!! На сколько я понял, то для работы с RL, лекарство корректно работает только до версии 4.23 с установкой RL-ARM из внешнего файла.

Проекты без RL в 4.50 у меня работают нормально!!

 

Share this post


Link to post
Share on other sites
Подскажите компилируются ли у Вас в 4.50 проекты с RL??

В 4.23а появился emWin, но с текущим лекарством проекты с emWin у меня не компилятся. В 4.50 внесли RL в дистрибутив кейла и теперь в новой версии у меня перестали компилиться проекты с RL (ошибка лицензии)!!! На сколько я понял, то для работы с RL, лекарство корректно работает только до версии 4.23 с установкой RL-ARM из внешнего файла.

Проекты без RL в 4.50 у меня работают нормально!!

У меня те же проблемы были и в 4,21, хотя люди писали, что у них таких проблем нет.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this