Jump to content

    
Sign in to follow this  
Артём__

Вышла Atmel Studio 6

Recommended Posts

Процик XMEGA32a4 вот такое простое решение как работа со строками по ком-порту есть ли? Или самому писать serialprint("data string"). Такая стандартная вещь но не нашел ее в asf

 

А разве обычный printf("data string"); не на UART выводит? На ASF не работала, но на IAR это так.

 

Share this post


Link to post
Share on other sites
А разве обычный printf("data string"); не на UART выводит? На ASF не работала, но на IAR это так.

 

Спасибо - работает. Думал может что-то готовое есть на DMA или на прерываниях.

Share this post


Link to post
Share on other sites

Дурацкий вопрос... Цветовую схему возможно ли изменить в Atmel Studio 6? В Visual Studio вроде бы через импорт настроек как то делалось

Share this post


Link to post
Share on other sites

Если включен Visual Assist: Глав.Меню -> V A Options -> Advanced -> Fonts and Colors

 

Сама IDE: Глав.Меню -> Tools -> Options -> Enviroment -> Fonts and Colors

 

Сам тоже долго искал

 

Импорт и экспорт делаю при переносе на др. рабочее место: Глав.Меню -> Tools -> Import and Export Settings

Edited by alexeyv

Share this post


Link to post
Share on other sites

Скачал вчера 6ю версию, поставил, поглядел, растроился что не получилось создать проект, удалил. Походу стала неудобнее и медленнее, возможно изза вижуал студии 2010. Весь в растройствах. будем пробовать повторно попозже... ;)

 

Откатился назад к 5й версии, там оно хоть и шустро и без головной боли.

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Вышла версия 6.1!

http://www.atmel.com/tools/ATMELSTUDIO.aspx

 

Atmel Studio 6.1 (build 2562) Installer

http://www.atmel.com/Images/AStudio61.exe

(568MB, updated April 2013)

This installer contains Atmel Studio 6.1 with Atmel Software Framework 3.8.1 and Atmel Toolchain.

 

Atmel Studio 6.1 (build 2562) Installer – Full

http://www.atmel.com/Images/AStudio61net.exe

(783MB, updated April 2013)

Share this post


Link to post
Share on other sites
Скачал вчера 6ю версию, поставил, поглядел, растроился что не получилось создать проект, удалил. Походу стала неудобнее и медленнее, возможно изза вижуал студии 2010. Весь в растройствах. будем пробовать повторно попозже... ;)

 

Откатился назад к 5й версии, там оно хоть и шустро и без головной боли.

Там же все просто.

Ставим 6.1 версию. При первом запуске она там пошуршит, распакует нужные файлы.

Затем оказываемся на стартовой странице.

Слева выбираем - Новый проект.

Затем - GCC С++ Executable project

После - выбираем чип.

 

Дальше как обычно, создастся пустой проект:

#include <avr32/io.h>

int main(void)
{
    while(1)
    {
        //TODO:: Please write your application code 
    }
}

Жмем F7 и смотрим, что все ок:

Build succeeded.
========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========

 

Все просто.

Share this post


Link to post
Share on other sites

Ой, а с 6.1 поставился новый тулчейн 3.4.2.1573 на базе gcc 4.7.2

LTO работает.

Линк на отдельный инсталлятор http://www.atmel.com/images/avr-toolchain-...2.win32.x86.exe

 

Со студией 4.19 интегрируется нормально

Edited by Genadi Zawidowski

Share this post


Link to post
Share on other sites

А в версии ARM GCC оптимизация LTO не включена... (в смысле, комилятор сообщает о том, что в данной версии выключено):

cc1.exe: error: LTO support has not been enabled in this configuration

Это и в cortex-m3 режиме и в arm7tdmi.

Edited by Genadi Zawidowski

Share this post


Link to post
Share on other sites

Да. Вот скачал AS6 по ссылке приведённой на этой ветке. Установилось, заработало. Подключил через кабель microUSB плату SAM4S XPlained. А она (плтат) нигде не видна. Хотя светодиодами помигивает (тот светодиод где jtag написано). Думаю как дальше её подключить

 

Да. Не к тому USB-порту на плате подключил. Заработало.

 

Нашёл J-link.

 

Но что-то J-link не хочет подключаться...

 

...Да.....

 

J-link это оказывается железка такая...

А Слава КПСС это вообще не человек...

Пойду покупать...

Share this post


Link to post
Share on other sites

Да. Подключил плату. Windows сказал что видит j-link и попытался сам установить драйверы. Не удалось.

Скачал сеггеровские драйверы. Распаковал установил. Всё равно плата SAM4S XPLAINED видна как неопределённое j-link устройство.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this