Jump to content

    

Fortun

Новичок
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Обычный

About Fortun

  • Birthday 08/06/1985

Контакты

  • Сайт
    Array
  • ICQ
    Array

Информация

  • Город
    Array
  1. Была у меня такая проблема на отладочной плате SAKURA v.2: подрубил первый раз плату по дебажному порту к ПК, включаю питание... и ничего, никаких обещенных буковок "СССС"... Ну да ладно, не впервой! :) Жму ресет - побежали буковки, но только "ггггг"! Именно при подаче питания на плату никакой реакции по дебажному порту, только после ресета! Метод "тычка" на TST1 не пробовал, фантазии не хватило :) Начинал проверять всю обвязку (фильтры PLL, номиналы их емкостей, кварцы...), пайку - ничего не помогало, все время бежали эти злощастные "гггг"! Когда генератор идей закончился и надежда угасла, рещил на всякий случай поменять этот западлянский ЧАСОВОЙ КВАРЦ (тот, который медленную тактовую частоту в контроллере задает, а также является источником клоков для дебажного битрейда). И точно, все сразу запустилось! Видимо я его немножко перегрел, когда его корпус к "земле" припаивал и его резонансная частота сместилась. Теперь все запускается сразу после подачи питание на плату. Попробуй кварц махни, может поможет :)
  2. IAR PowerPac for ARM

    Однажды тоже ради интереса решил PowerPac опробовать, скачал самый новый PowerPac и собственно сам IAR Workbench for ARM (тогда была версия 5.11, не знаю, может ща есть и новее)... ну и такая же беда, говорит, что на ПК нет нужной версии IAR для продолжения установки - я и забил на все это. Но, как-то капаясь в IARовских папках наткнулся на каталог PowerPack, в котором было все (я так понимаю), что было бы, если эта злополучная установка все-таки состоялась! Другими словами, в дистрибе IAR (версии 4.41! может есть и в предыдущих, но более ранних версий у меня не было) уже идет встроенный PowerPack! Может для кого это совсем не новость, но я об этом узнал совсем недавно и чисто случайно... Так что погляди в IARовском каталоге, там есть то, что ты ищешь! :)
  3. ПОМОГИТЕ, ПЛИ-И-И-И-З!!! Пишу на CodeVision прогу под SD на ATMega16. На первую команду (CMD0 = 0x40) карта в ответ выставляет "1" - всё как и положено. Подаю вторую команду (CMD1 = 0x41) в цикле - карта упорно держит "1" и не желает сбрасывать но "0"... И, вообще, сколько раз нужно подавать команду 0xff ??? По даташиту - 74, но сколько исходников смотрел, во всех разное количество (в том числе и в FlashFileCD - числом 74 и не пахнет!), НЕПОНЯТНО... :huh: