Jump to content

    

A-10

Участник
  • Content Count

    85
  • Joined

  • Last visited

Community Reputation

0 Обычный

About A-10

  • Rank
    Частый гость

Контакты

  • Сайт
    Array
  • ICQ
    Array

Информация

  • Город
    Array

Recent Profile Visitors

1588 profile views
  1. max30102, h=1.5мм флюса лью не так, чтобы много, просто размазываю флюс вдоль падов. понял, у меня был аналог упомянутого вами, однако без вытяжки я его бы больше не рискнул применять -) чистит отлично, это да. насчет варианта придавить после расплавления - действительно, можно попробовать. КЗ после запайки легко проверяется, т.к. все выводы легко доступны.
  2. К сожалению, трафарета нету ( Дозатор ручной Techcon ts700. Не знаю, можно ли им нормально укладывать пасту на небольшие площадки, возможно нужна игла с минимальным диаметром отверстия. С текущей у меня получаются излишки пасты и перемычки. Паста - EFD Solderplus 62NCLR-A. Меди нет снизу, плата (в этом месте) - однослойная гибкая, она очень быстро прогревается. Фен - Leister Hot Jet S. Индикации т-ры нет, т-ра устанавливается потенциометром (но в целом обычно ставлю на "3" и получается ~300 градусов на 3-4см). Поток ставлю на минимум, флюс как раз 6-412a. Использую микроволну при облуживании. Спасибо за подробную инструкцию. В целом я примерно так все и делаю, QFN микросхемы обычно напаиваются без проблем (хоть у меня и нет постоянной практики). Разве что сопла такого диаметра у меня нет, только одно в наличии и вариант - без сопла вообще (тогда площадь достаточная). Я думаю, что наношу припой на пады не равномерно и получается, что некоторые из них в итоге висят в воздухе (смотрел сбоку под микроскопом, когда не удачно запаял). Насчет много флюса - всегда следовал этому принципу, но тут начал беспокоиться из-за попадания флюса внутрь сенсора (верхняя часть имеет прозрачное окно и корпус разделен на 2 части, с верхней крышкой). Сейчас думаю почистить иглу и попробовать вариант с нанесением пасты. Кстати, какой очиститель можно использовать для удаления флюса? Так, чтобы не отравиться без вытяжки -)
  3. Спасибо всем за советы, получилось посадить модуль почти идеально (один пад не пропаялся, пришлось немного пасты туда поднести и прогреть). я это всегда контролировал визуально и уже в целом понимаю, когда какую т-ру выставлять, а документацию скинул для конкретики. вопрос был задан для того, чтобы понять, может быть есть какие-то общепринятые рекомендации -) @mplata отличный совет по поводу оплетки и фена, раньше всегда паяльником снимал, а тут оценил достоинства метода, спасибо. точно, я забыл, что нижний подогрев нужен для уменьшения разности температур и преднагрева не до т-ры плавления. Еще вопрос по монтажу, есть сенсор в таком корпусе: Имеющийся на плате был запаян неверно при монтаже на производстве и, вероятно, поврежден (сажали, к тому же, феном, как я понимаю, т.к. края корпуса оплавлены). Изначально пробовал перепаять имеющийся на плате, нанес припой и флюс равномерно на пады на плате и грел феном - сенсор постоянно норовил улететь, т.к. очень легкий. В итоге получилось запаять иначе, облудив пады на сенсоре, а пады на плате зачистив от излишков припоя, но он все же не заработал. При последней попытке перепаять корпус распался на две части (они склеены, видимо) и внутренние соединения начали отпаиваться. Т-ру ставил в районе 300. Попробовал поставить новый, начиная с более низкой т-ры и смотреть, когда начнет садиться. Обнаружил, что флюс при нагреве снизу начинает проникать в корпус.. Пришел к выводу, что наиболее безопасный вариант, видимо, нанести пасту на пады и не добавлять флюса. К тому же, паста обычно лучше держит компонент до расплавления. Однако, есть проблема с нанесением - из вариантов только ручной дозатор (игла достаточно толстая и получаются излишки припоя) или нанесение пасты подручными средствами, типа иглы. Во втором варианте тоже сложно дозировать пасту. Может кто-то посоветует, есть ли тут нормальный подход, позволяющий нормально посадить такой корпус?
  4. насчет фена - очень полезное замечание, все время грел с узким соплом.. видимо, все сводится к правильной дозировке припоя, несколько раз до этого пробовал как раз накатывать "шары" на модуль и чистить площадки на плате, оставляя немного припоя, но выходило не очень. модуль имеет свойство съезжать от потока воздуха и не самопозиционироваться как обычные микросхемы, то ли из-за разнесенности контактов, то ли из-за неравномерности прогрева. ну или я не вижу этого момента, т.к. ножки все сбоку. Да, тоже думал об этом устройстве, смотрел несколько месяцев назад обзор на него, но не заказал. Надо попробовать. Хотя данная плата - с элементами на двух сторонах, я не знаю такие греют вообще - компоненты снизу явно начнут отваливаться. Припой вот такой https://www.aimsolder.com/sites/default/files/glowcore_cored_wire_tds.pdf Обычно паяю на 275 градусов, но пад с N-ой попытки все равно отвалился -) Флюс - Efd solder flux.
  5. нижнего подогрева, к сожалению, нету, как и печи. спасибо. то есть, я верно понимаю, на плате должны быть совершенно гладкие облуженные пады, а на модуле - одинаковые по форме/высоте наплывы припоя? флюс до установки совсем не добавлять, получается? видимо, это тоже влияет, т.к. я обычно добавлял его сразу. насчет греть площадки паяльником - увы, не получается. монтаж довольно плотный, да и в целом дотянуться до пада, не оставляя перемычек получается только самым тонким жалом, а оно не прогревается в самой тонкой части нормально (поднести припой не получалось к точке пайки, поэтому пробовал плавить на жале). и еще такой вопрос - какую т-ру выставлять на станции для "реболлинга" падов на модуле? у меня просто были случае отваливания падов от т-ры, хотя стараюсь быстро их проходить.
  6. Доброго времени суток всем, Столкнулся с проблемой при пайке такого модуля (габариты и размер видно на фото). Проблема в том, что при пайке феном всегда остаются непропаянные пады. Подозреваю, что модуль немного перекашивает и он не садится некоторыми ногами (визуально сложно понять). Пробовал прогревать после неудачного монтажа, снимать и пересаживать на облуженные паяльником пады - не удается гарантированно поставить его, всегда остаются непропаянные площадки. Нормально паяю все SMD корпуса до QFN/LGA, но с таким корпусом не сталкивался раньше. Из оборудования - фен, микроскоп. Есть паста, но без трафарета наносить проблемно на такие пады (только ручной дозатор). Возможно, кто-то знает проверенный подход к пайке такого рода корпусов?
  7. Не подскажите, сколько времени занимает доставка по СПб, при учете, что товар есть на основном складе? Сроки доставки не указаны при заказе, не хочется ждать неделю после заказа.
  8. Спасибо за совет, нашел подходящий вариант (на SSOP правда, но должна влезть). У TXS это самый простой корпус, остальные - QFN/BGA. Как проверю, отпишусь. Я уже писал выше, что питание IO пинов камеры (OV7670 модуль) ~2.8В, 3.3В идут на модуль (внутри LDO). Шин несколько, я в итоге для чистоты экспериментов остановился на той, где нет иных устройств, кроме подключаемой камеры. Хочу опять же напомнить, что меня более всего смутили сбои при подключении щупов осцила/анализатора, без модуля камеры. Завтра надеюсь разобраться с переходником, потом, если данные нормально пойдут, буду пробовать отдельно разобраться с i2c. p.s. Смотрел настройки пинов в dt-bindings/pinctrl, режим стоит - открытый коллектор, 34 Ома выходное сопротивление драйвера (минимально возможное, конфигурируется).
  9. Честно говоря - никак. Припаять все пины у TSSOP микросхем нормально не получилось (провода тонкого нет, получаются спайки и ноги норовят отвалиться от перегрева). На выходных попробую откопать кусок текстолита и вспомнить старый добрый ЛУТ, сделаю небольшой переходник и подпаяю нормально. То есть изначально земля процессорного модуля соединялась с корпусом? А корпус был заземлен?
  10. Вы писали: "обратный левел-шифт из низковольтового домена в высоковольтовый", а тут 2.8В от камеры в 1.8В, высоковольтный в низковольтный. Думаю, просто ошибка, но я понял о чем речь. Микросхемы уже сегодня-завтра будут, так что можно будет проверить и убедиться.
  11. Это именно клоки камеры. Просто после модификации обратного клока i2c опять пошла вразнос. Не совсем понял. Толерантность по питанию требуется же при преобразовании из high->low, когда на вход подается более высокое напряжение. А при преобразовании low-to-high питание идет высокое, а открывается "низким" уровнем. И судя по сигналам, по части клока все нормально. На линии данных приходят нули (там уровень так же задавлен до 1В и не воспринимается входными буферами), поэтому картинка черная (точнее, зеленая, т.к. YUV цвет. пространство). Сейчас нет под рукой названия микросхемы, дома посмотрю. Попробую найти TXS0108E и повесить на плату, пропущу i2c и клоки в обе стороны, чтобы убедиться, что не будет сюрпризов. p.s. Вы правы по части адреса, 0x42 >> 1 = 0x21
  12. Тут нет селектора и все линии у меня к чему-то подтянуты.. Возможно. Однако, есть линия I2C-0, на которой вообще пусто, но на ней тоже происходят подобные сбои (фантомные девайсы появляются, а потом линия падает в ноль). Кроме того, после первого исправаления при тестировании hdmi не мешал абсолютно. Большинство микросхем в наличии <= 8 бит, не удобно разбивать, 8 бит на данные входящие, а остальные сигналы разнонаправленные. Да и так больше шансов, что tpd у сигналов будет одинаковое..
  13. Микросхему (NOR) я напаял сверху и подключил ее вместо преобразователя (частота слишком высокой оказалась для такой схемы на мосфетах), для линии входной частоты. Старые дорожки разрезал, чтобы не было антенного эффекта. В это время i2c протокол работал хорошо, удалось обнаружить камеру по i2cdetect. Правда адрес отличался от того, что указан в ДШ, этот момент я не понял. После чего я допаял еще одну микросхему NOR, дабы пустить через нее обратный сигнал частоты от камеры. И начались (продолжились) вышеописанные глюки. Длина линий не более 15см, номиналы со стороны проца ~2.35K(после допайки резисторов), со стороны камеры - 2.2К. Напряжение IO пинов камеры - 2.8В, проца - 1.8В. На этой линии висит только лишь HDMI трансмиттер -по нему видно, что передача идет нормально, когда нет камеры на линии, иначе просто не идет сигнал на монитор. Errata молчит. Про пулапы я почитал, все вписывается по расчетам. С камерой все нормально, ресет подтянут к уровню, она выдает все сигналы синхронизации и данные. Хочу передалать схему на полноценном преобразователе уровня, удалось найти из двунаправленных (без DIR пина) только txs0108e. По характеристикам подходит, поддерживает push/pull / open drain и по частоте тоже запас.
  14. Согласен, наводки от тактовой визуально не видны и разницы до/после модификации по форме сигнала нету. Попробую посмотреть в стороны i2c/gpio.
  15. А уж было думал, что проблема решилась полностью, но нет -) После добавления второй микросхемы для согласования уровня (на обратной стороне платы припаял проводами, закрепив клеем) i2c стала сбоить снова. Причем ситуация такая, на линии i2c-1, где помимо камеры висит hdmi, при старте платы и линуха, пытается инициализироваться этот hdmi, но заваливается SDA: На пустой линии i2c-0, если туда вешать камеру, вылазит такое (на этот раз SCL): Причем, иногда проходит несколько команд, находятся фантомные устройства на линии, но потом неизменно SCL падает. Вероятно, дело в наводках на линию I2C с обратной частоты 27МГц, которая идет по проводу к разъему.