Перейти к содержанию

    

Deadhunters

Участник
  • Публикаций

    11
  • Зарегистрирован

  • Посещение

Репутация

0 Обычный
  1. KSZ8895RQX потеря пакетов

    Вообщем пришла плата с завода, с немного другой разводкой и все работает хорошо. В чем была проблема так и останется тайной. Возможно изготовленная ЛУТОМ плата имела непротравы..
  2. KSZ8895RQX потеря пакетов

    Частотомера нет, а осцил не всегда правильно показывает, но из того что смог замерить, частота от 49.98 до 50.05, большую часть времени держится 50 ровно, редко скачет до 50.05, а менее 50 пару раз в минуту. Кажется на данный момент перепробовал уже все. З.Ы А как можно определить что плохо работает? Сигналы на Tx и Dx по форме одинаковы, т.е он что то принимает и что то отправляет, только вот как узнать что? По поводу счетчиков, не смог найти такого. По итогу: Менял микросхему, снимал трансформатор, несколько раз менял кварц и совсем убирал его кондеры, убирал всю обвязку трансформатора, запитывал свитч от батарейки, соединял опорную землю до трансформатора с основной землей, менял местами Rx Tx, меня в диф парах + и - местами, отключал MDI-X, пробовал сначала подать 3.3 и сразу же 1.2в питания (вручную), менял номинал резистра на ISET (по даташиту 12.4кОм) ставил подстроечник, и ничего из этого не дало практически никакого результата, единственное после впайки кварца с материнки ПК немного улучшилась передача из 10 в 100, доходит примерно 15% пакетов. Сегодня попробовал тактировать кварцевым генератором на 25Мгц, но генератор на 5в, а при запитке от 3.3. уже нет синусоиды, запустить не удалось. Из оставшихся вариантов - купить микруху из другой партии, либо заказать плату на заводе, но даст ли это положительный результат неизвестно. Всем спасибо за помощь, если будут еще какие либо идеи буду благодарен.
  3. KSZ8895RQX потеря пакетов

    На 60 ноге стоял - 50мгц есть. Порты работают все, линк есть на всех. Если стоять на дифф парах, причем мне важно RX или TX - сигнал есть. Уровень и форма сигнала соответствуют эталонным девайсам (свитч, пк).
  4. KSZ8895RQX потеря пакетов

    Попробовал вручную подать 3.3, и сразу же 1.2, результата нет. По поводу 22пф, верно подмечено, уже не помню точно, но такие конденсаторы применял. Сейчас убрал их совсем - результат тот же. Попробовал убрать еще и резисторы от средних точек - ничего.
  5. KSZ8895RQX потеря пакетов

    1) Все верно, на 17-й ноге резистор в землю стоит (а подтяжка к + на схеме была сделана, т.к. на момент разводки в даташите лень искать было куда тянуть 17 пин) 2) Можно подробнее про порядок подачи? Если правильно понимаю сначала 1.2В, а затем 3.3? и с каким интервалом? Чип немного теплый во время работы, градусов 30-40.
  6. KSZ8895RQX потеря пакетов

    После впайки кондеров с той же материнской платы (которые на кварце) ситуация улучшилась, из 10 в 100 50% потерь, из 100 в 100 - 82% потерь, это при длине пакета 32 байта.
  7. KSZ8895RQX потеря пакетов

    на выводе сброса стоит кондер и супервизор
  8. KSZ8895RQX потеря пакетов

    Вот схема питания и сигнальной части Все брал из даташита и eval board, единственное замечание - пробовал убирать резисторы и конденсаторы от средних точек, никак не повлияло на работу. А как проверить работу "сам на себя"? Если в режиме 100 мбит стать на дифф пару, то сигнал есть, достаточно ровный. При соединение двух портов между собой линка нет, но если подключить ПК и послать пинг, то линк бегает даже после отключения ПК.
  9. KSZ8895RQX потеря пакетов

    Светодиоды установлены верно т.к при включении PS 0,1 - 11 тестовый режим, все светодиоды на всех портах зажигаются. Да, еррату смотрел, были разные патчкорды от 2-х до 10 метров в обе стороны, на передачу абсолютно никак не влияет. Кварц менял 3 раза, в данный момент установлен с материнской платы (стоял рядом с ethernet). Так же пробовал убрать конденсаторы по 22pf. немного изменилась форма синусоды кварца. Ps. как с помощью осцила измерить ppm?
  10. KSZ8895RQX потеря пакетов

    Какая часть схемы и платы инетересует? Осцил АКТАКОМ ADS-2221MV (2Gsa/s на 200 МГц) Извиняюсь, опечатка, LD1117 3.3
  11. Добрый день! Ситуация следующая. Есть самодельная плата на KSZ8895RQX используется только 4 порта, 5-й разведен под RMII, при подключении любых устройств с ограниченной скоростью в 10 мбит, пингуется нормально, при размере пакета в 2048 байт начинаются потери пакетов около 1-2%, длина одного ethernet кабеля около 1м, второго - 5 м. Если с устройства 10 мБит пинговать 100 мбит, потеря пакетов доходит до 90%, а из 100 в 100 - пинг проскакивает очень редко. Питание - DC-DC 12/5 на LM5007, после идет LD1117 3.0 и LD1117 1.2, установлены дроссели электролиты и керамика по 2.2 мкф, помехи по линиям питания с размахом 15 мВ максимум, рядом с каждым пином питания установлена керамика 0,1мкф. При снятии осцилограммы с диф пар отклонений не вижу (сравнивал с сигналами от ПК, и другим свичом). Есть доступ к регистрам (с помощью переходника на ардуино - https://fabiobaltieri.com/2011/08/19/5p-switch/). Установлен трансформатор EPCOS A8250, пробовал подключать ethernet кабель напрямую к МК, результата нет. Резистор на выводе ISET 12.4 кОм, пробовал менять номинал. Плата двухслойная, под МК на первом слое разведен земляной полигон, AGND и DGND представляют общий полигон без точки соединения, и связана кондером на 2кВ с опорным слоем диф пар до трансформатора. Пробовал соединить без кондера - результата нет. Линк на 100 мБит есть. Еще заметил странную особенность, светодиод указывающий скорость LED 2-0 не отрабатывает, хотя подключение 100 мБит, на остальных портах такой проблемы нет. Пробовал заменить МК - безрезультатно. Буду очень благодарен за любую помощь, перечитал кучу форумов, включая англоязычные, ничего не смог найти.