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      Электромагнитное моделирование Analyst 3D 
В этой главе описана конфигурация и использование программы трёхмерного электромагнитного 

моделирования Analyst 3D. Эта программа использует метод конечных элементов в частотной области 
(Finite-Element Method - FEM) с тетраидной сеткой в трёхмерном объёме, который может содержать металл, 
воздух и диэлектрик. Встроенная сетка улучшается в течение нескольких итераций, чтобы оптимизировать 
качество решения. Моделирующая программа Analyst 3D не делает никаких предположений или 
приближений относительно конфигурации и её можно использовать для любой модели. Analyst 3D может 
использоваться как самостоятельная программа или её можно использовать для структур, созданных в 
AXIEM без или с минимальными изменениями, хотя это займёт большее время для моделирования и 
потребует больше машинной памяти. Analyst 3D также создаёт больше наборов данных, чем AXIEM. 

Выбор Analyst или AXIEM. 
Analyst 3D используется чтобы моделировать: 

 Трёхмерные структуры, например волноводы или соединители. 
 Трёхмерные pcell например соединительные провода и шаровые выводы. 
 Планарные структуры с трёхмерными эффектами, например толстый металл. в котором глубина 

скинслоя сопоставвима с толшиной металла, много земляных плоскостей (метод конечных 
элементов может иметь преимущества в скорости анализа), металлические корпуса и 
диэлектрические вставки. 

 При исползовании AXIEM каждый диэлектричевкий слой считается бесконечным, чьо не всегда 
оправдано. Например, для расчёта выводов печатной платы микросхемы на арсениде галлия 
лучше использовать Analyst 3D. 

Различия в установках структур в Analyst и AXIEM. 
Чтобы выбрать AXIEM или Analyst, нужно рассмотреть конфигурацию модели, основные установки 

параметров, сетку и различия базовых установок. 
 В Analyst нужно определить полную поверхность для 3D вычислений так как в объём воздуха 

вокруг структуры встраивается сетка и он включается в анализ. 
 Analyst поддерживает типы портов AXIEM, но и допускает использование волноводных портов, 

которые не поддерживаются AXIEM. Волноводный порт - плоская поверхность, обычно 
ориентируемая так, чтобы сигнал проводников или волновода пересёк поверхность под прямым 
углом, и выполнить анализ для возникших мод, которые возбуждаются в полном ЕМ вычислении. 

 Существует разнообразие 3D pcell, которые можно использовать только в Analyst. 

Недостатки Analyst. 
Analyst имеет следующие недостатки: 

Нет решений для постоянного тока. Вместо постоянного тока используется низкая частота, значение 
которой по умолчанию 10 МГц. Эта частота заменяет любую частоту, значение которой задано меньше. В 
результате потери и другие величины на постоянном токе могут быть вычислены неправильно. 
Нет исключения неоднородностей сосредоточенных портов. 
Не поддерживается произвольная ориентация дочерних ЕМ структур. 

Преобразование проектов AXIEM в проекты Analyst. 
Чтобы преобразовать проект AXIEM в проект Analyst 3D: 

1. Щёлкните правой кнопкой мышки по имени ЕМ структуры в левом окне просмотра проекта и 
выберите Set Simulator. В открывшемся окне отметьте AWR Analyst 3D EM - Async. 

2. По умолчанию, граничные формы вычерчиваются немного больше, чем конфигурация структуры. 
Измените границы для структуры соответствующим образом. Обычно границы определяются на 
10-ти кратном от толщины диэлектрика расстоянии от любых проводников на сторонах без 
волноводных портов. Если используются волноводные порты, то они должны быть на границе. 

3. Гарантируйте, что порты установлены корректно. Analyst поддерживает все порты AXIEM, за 
исключением внутренних портов, неявно подключённых к земле. 

4. Щёлкните правой кнопкой мышки по имени ЕМ структуры в левом окне просмотра проекта и 
выберите Options. В диалоговом окне Options на вкладках Mesh в Analyst имеется набор опций. 
Как правило, установки по умолчанию достаточны. 

Установка конфигурации геометрии в Analyst. 
Конфигурация, которую использует Analyst, создаётся в том же редакторе, в котором создаётся 

конфигурация для любого ЕМ решающего устройства (AXIEM или EMSight). ЕМ структуры в Analyst также 



поддерживают дополнительные трёхмерные компоненты, типа параметризированных ячеек (pcell), 
соединительных проводов, шариковых выводов, конических перемычек и других. В структуре Analyst 
можно определить вытянутые двухмерные формы и перемычки как проводники или диэлектрики (в AXIEM 
поддерживаются только проводники). 

Использование сетки черчения. 
Можно использовать сетку для черчения при создании ЕМ структуры в Analyst. Дважды щёлкните 

по Enclosure под именем структуры в левом окне проекта или щёлкните по значку Substrate Information на 
панели инструментов, чтобы открыть окно Element Options - ENCLOSURE Properties. Откройте вкладку 
Enclosure. Параметры Grid_X и Grid_Y определяют сетку для черчения. 

Черчение форм. 
Формы вычерчиваются как и в любой другой моделирующей программе. 

Добавление диэлектрических форм. 
Analyst может моделировать конечные диэлектрики. В STACKUP определяются диэлектрические 

слои, которые непрерывны по всей структуре. Чтобы определить диэлектрическую вставку с размерами 
меньше корпуса, нужно добавить форму так же, как для проводника, но определить материал диэлектрика 
вместо проводника. 
Приоритет материала с перекрытиями. 

В структуре не должно быть перекрывающихся форм. Если перекрывающиеся формы имеются, их 
надо разделить. Для этого используется автоматическая процедура, которая использует несколько простых 
норм, которые определяют, какой материал имеет приоритет, когда две трёхмерные формы перекрываются 
внахлёстку 
Просмотр трёхмерной модели, используемой моделирующей программой. 

Перед выполнением анализа полезно просмотреть трёхмерное отображение ЕМ структуры, чтобы 
проверить её на наличие ошибок. Чтобы сделать это, выберите в меню View>View 3D EM Layout или 
щёлкните по значку View 3D EM Layout на панели инструментов. При открывшемся окне 3-х мерного 
отображения структуры  выберите в меню View>Visual>Merged 3D Model. 
Использование трёхмерных параметризированных ячеек (pcells). 

Трехмерные параметризированные ячейки (pcells) - это специализированные типы элементов 
топологии, которые можно добавить к двухмерной топологии. Эти элементы топологии можно 
редактировать, как и любые другие. 

Analyst может использовать трехмерные pcells в MWO для 
следующих трехмерных конструкций: 
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 Bond wire (соединительный провод). 
 Ball Grid Array - BGA (шариковые выводы). 
 Ribbon (лента). 
 Tapered Via (коническая перемычка). 
 Thin Film Capacitor (тонкоплёночный конденсатор). 

Чтобы добавит pcells в топологию ЕМ структуры: 
1. При активном окне двухмерной топологии щёлкните по 

кнопке Add на панели инструментов, чтобы добавить 
желательную pcells (рис.1). 

2. После выбора добавляемой pcell программа находится в 
режиме размещения. Отображается светлое изображение топологии pcell, которое перемешается 
вместе с курсором. Щелчок правой кнопкой мышки поворачивает pcell на 90 градусов. Чтобы 
повернуть pcell относительно оси Y нажмите клавишу Ctrl и щёлкните правой кнопкой мышки. 

Чтобы повернуть pcell относительно оси X нажмите 
клавишу Shift и щёлкните правой кнопкой мышки. 

Рис. 1 

3. Каждая pcell знает, на каком слое она расположена. При 
добавлении pcell она добавляется к активному слою. 
Щёлкните по панели Layout в левой нижней части окна, 
чтобы открыть окно менеджера топологии и установите 
активный слой, щёлкните по стрелке в правом конце 
строки EM Layer, чтобы открыть выпадающее меню, 
установите нужный слой и материал (рис. 2). 

4. Перемычка будет добавлена к отмеченному слою. Нельзя 
добавить перемычку к слою 1, или если установлено EM 
layer undefined. 

После добавления pcell к двухмерной топологии можно редактировать её двухмерные свойства 
обычным образом, как и любую форму (изменять длину, поворачивать и т. д.). 

Рис. .2 

Трёхмерные свойства pcell можно определить, если щёлкнуть по ней сначала левой кнопкой 
мышки, затем правой и выбрать Element Properties. 



Можно перемещать pcell по слоям, щёлкая по кнопкам Move Up  и Move Down  на панели 
инструментов. 

Можно щёлкнуть по pcell сначала левой кнопкой мышки, затем правой и выбрать Shape Properties, 
чтобы открыть окно Cell Options. На вкладке Layout в области Z Position можно определить слой для 
размещения pcell и ввести смещение Offset по оси Z. В этом же окне можно поворачивать pcell 
относительно осей X, Y и Z. 
Импортирование геометрии топологии. 

ЕМ структуру можно непосредственно импортировать в GDSII или DXF файлы. Для этого нужно 
щёлкнуть правой кнопкой мышки по EM Structures в левом окне проекта и выбрать Import DXF или 
Import GDSII. 
Создание иерархической ЕМ структуры. 

Можно создавать иерархические ЕМ структуры, добавляя другие ЕМ структуры в качестве подсхем. 
Если, например, есть ЕМ структура микросхемы на арсениде галлия (GaAs), которая имеет два 
диэлектрических слоя (арсенид галлия и воздух), и нужно эту микросхему поместить на верхнем слое платы 
или в корпусе с соединительным проводом, то обычно создаётся ЕМ структура платы (два слоя в 
простейшем случае). Затем можно к ЕМ структуре платы добавить ЕМ структуру микросхемы в качестве 
подсхемы без дополнительного создания диэлектрического слоя. Это позволяет выполнить анализ отдельно 
для каждой ЕМ структуры и затем объединить результаты. 

Чтобы добавить в ЕМ структуру в качестве подсхемы другую ЕМ структуру, выберите в меню 

Draw>Add Subcircuit или щёлкните по значку Subcircuit  на панели инструментов. В открывшемся окне 
выберите ЕМ структуру, которую нужно добавить в качестве подсхемы, и нажмите OK. Размещение и 
редактирование подсхемы делается так же, как и для трёхмерных pcell. 

Определение поверхностей раздела для анализа. 
Для каждой структуры в Analyst должны быть определены граничные условия. Только формы 

внутри поверхности раздела  анализируются, и все порты должны быть внутри или на периметре 
поверхности раздела. Тип порта частично определен позиционированием порта относительно поверхностей 
раздела. Поверхности раздела определены формой в двухмерной топологии ЕМ структуры, которая 
окружает остальную часть топологии. Границы выбираются для вершины, основания, и сторон. По 
умолчанию границы определяются как Approx Open (открытое пространство). 
Редактирование граничных форм. 

При создании ЕМ структуры для Analyst или конвертировании ЕМ структуры в Analyst граничные 
формы добавляются по умолчанию. Есть два способа редактирования граничных форм: 

 Редактировать существующую граничную форму, дважды щёлкнув по ней, чтобы поместить её в 
режим редактирования, затем перетащить любую вершину или середину ребра. 

 Начертить любую форму или выбрать любую форму в ЕМ топологии. Выберите в меню Choose 

Draw>Create Simulation Boundary или щёлкните по значку Create Simulation Boundary  на 
панели инструментов, предварительно щёлкнув левой кнопкой мышки по границе. 

 Если определено больше одной граничной формы, анализ не выполняется и выводится сообщение 
об ошибке. В этом случае удалите все дополнительные граничные формы перед выполнением 
анализа. 

Замечание. Если имеется более одной граничной формы, нельзя будет выполнить булевы операции, 
чтобы создать более сложную граничную форму. Поэтому, если нужно создать сложную форму для 
граничных условий, сначала нужно создать форму на любом другом слое. На этом слое можно выполнить 
любое редактирование сложной формы и затем использовать первый вариант, упомянутый выше, чтобы 
преобразовать форму в граничное условие. 
Граничный размер. 

Граничный размер может существенно влиять  на точность результатов анализа, особенно если 
поверхность раздела слишком близка к металлическим формам. В простых случаях можно поместить 
боковые стенки и верхнюю поверхность на расстоянии не менее 10-ти толщин подложки. В этом случае на 
результаты практически не влияет как определены граничные условия, герметичная электронная схема 
(PEC), идеальный магнитопровод (PMC) или открытое пространство. Для более сложных конфигураций, 
возможно, придётся экспериментировать, чтобы определить минимальные граничные размеры. Это 
требование относится ко всем сторонам, которые не содержат портов. 

Для излучающих структур граничное условие PML дает самые точные результаты. Вообще, самые 
близкие граничные стенки должны быть на расстоянии как минимум одна четверть длины волны от 
металлической формы. 
Выбор граничных условий. 

Поля моделируются только в пределах корпуса, и обработка полей на поверхности раздела корпуса 
определяется выбором граничных условий. Вообще, граничные условия могут определить значения 
компонентов электрического или магнитного полей, или они могут определить зависимости между E и H. 

В таблице 1 показаны типы граничных условий, которые поддерживает Analyst. 
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Таблица 1. 

Типы 
состояний 
границ 

Влияние 
на E 

Влияние 
на H 

Рекомендуемый размер границ Замечания по использованию 

Perfect Electric 
Conductor 
(PEC)  

E∥ = 0 H⊥ = 0 

Обычно используется при 
моделировании в корпусе с 
токопроводящими стенками. 
Размеры определите так, чтобы они 
соответствовали фактическому
прибору. 

  

Perfect 
Magnetic 
Conductor 
(PMC)  

E⊥ = 0 H∥ = 0 
На расстоянии 5 - 10 высот 
подложки от металлических форм. 

Альтернативно можно 
использовать Approximate Open.

Impedance E∥/H∥ = Z 

Обычно используется при 
моделировании в корпусе с 
токопроводящими стенками. 
Размеры определите так, чтобы они 
соответствовали фактическому 
прибору. 

Обычно используется, если для 
верхней и нижней крышек 
определён материал с потерями. 

Approximate 
Open 

E∥/H∥ = 376.7Ω 
На расстоянии 5 - 10 высот 
подложки от металлических форм. 

Используется для неизлучающих 
структур, чтобы 
аппроксимировать свободное 
пространство. Не использовать 
для излучающих структур. 

Perfectly 
Matched Layer 
(PML) 

См. ниже 
На расстоянии > λ/4 от 
металлических структур. 

Предназначен для использования 
в излучающих структурах. В 
вычислительном отношении 
дорогой. 

Electric 
Symmetry 

E⊥ = 0 H∥ = 0 n/a 

Используется только когда 
имеется геометрическая или 
электромагнитная симметрия. 
Должен делить все порты 
пополам. 

Magnetic 
Symmetry 

E∥ = 0 H⊥ = 0 N /a 

Используется только когда 
имеется геометрическая или 
электромагнитная симметрия. 
Должен делить все порты 
пополам. 

Редактирование граничных условий. 
Есть два способа редактирования 

граничных условий: 
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 Щёлкнуть по граничной форме 

левой кнопкой мышки, затем 
щёлкнуть правой кнопкой и 
выбрать Shape Properties, 
чтобы открыть диалоговое окно 
Properties. Затем открыть 
вкладку Boundary Conditions. 

 Дважды щёлкнуть по Enclosure 
под именем ЕМ структуры в 
левом окне просмотра проекта 
или щёлкнуть по значку 
Substrate Information на панели 
инструментов, чтобы открыть 
диалоговое окно Properties. 
Затем открыть вкладку 
Boundary Conditions. 

Откроется окно Properties, 
показанное на рис. 3. 

Рис. 3 



 По умолчанию, каждая сторона использует установку, которая определена в поле Side Boundary. По 
умолчанию это Approx Open (свободное пространство). Щёлкните по кнопке в правом конце этого поля и 
выберите другую установку. Установки для всех 4-х сторон будут автоматически изменены на новую 
установку, которая определена в поле Side Boundary. Можно определить установку для каждой стороны 
индивидуально. Для этого снимите отметку в Use Side Boundary. Щёлкните мышкой по нужной стороне в 
столбце Edge Index. Эта сторона в топологии будет выделена синим цветом. Затем щёлкните по строке в 
столбце Edge Boundary condition. В правом конце этой строки появится небольшая кнопка, щёлкнув по 
которой мышкой можно изменить граничное условие этой стороны. 
Просмотр граничных условий. 

Рекомендуется просмотреть граничные условия в трёхмерном отображении, чтобы убедиться, что 
они установлены правильно. Чтобы сделать это, 
откройте трёхмерное мерное отображение ЕМ 
структуры и щёлкните по значку Show Boundary 

Conditions  на панели инструментов. Будут 
отображены граничные условия ЕМ структуры в 
виде куба по умолчанию обычно красного цвета и 
под именем ЕМ структуры появится аннотация 
EM_3D_SURF_BC. Дважды щёлкнув мышкой по 
имени аннотации можно изменить её свойства. 
Если открыть окно менеджера топологии, то в окне 
Visibility By Material/Boundary перечислены 
используемые материалы и цвета, которыми они 
отображаются (рис. 4). В столбце Visible можно 
отключать или включать отображение каждого 

материала. Если в столбце Color щёлкнуть мышкой по какому-нибудь цвету, то в правом конце появится 
небольшая кнопка. Щёлкнув по этой кнопке можно изменить цвет. 

Рис. 4 

Щёлкните по кнопке Show Boundary Conditions на панели инструментов снова, чтобы выключить 
отображение граничных условий. 
Использование граничной формы, чтобы обрезать (усечь) структуру. 
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Можно использовать граничные поверхности, чтобы анализировать подмножества начерченной 
конфигурации. Только для форм, расположенных внутри граничных плоскостей, выполняется анализ. 
Любые добавленные порты для анализа должны быть расположены внутри границ или на стороне границы, 
иначе выводится сообщение об ошибке. 

Рис. 5 Рис. 6 

На рис. 5 показана простая линия, помещённая в корпус, образованный граничными плоскостями. 
Можно отредактировать эту структуру так, что только часть линии будет внутри граничных плоскостей 
(рис. 6). В этом случае порт 2 находится за пределами граничных плоскостей и анализ выполняться не будет 
с выдачей ошибки. 

Рис. 7 Рис. 8 



На рис. 7 порт 2 добавлен к правой граничной плоскости и анализ будет выполнен для части линии, 
находящейся внутри граничных плоскостей. Если просмотреть сетку, встроенную в структуру для анализа, 
то будет отображена только часть структуры, находящейся внутри граничных плоскостей (рис. 8). 

Добавление портов. 
В Analyst порты добавляются также, как и в AXIEM. Порт может быть добавлен к любой стороне на 

граничной поверхности и к любой стороне внутри границ раздела, если порт 
является дифференциальным или имеет явное подключение к земле. 
Поддерживаются волноводные и сосредоточенные порты. Тип порта определяется 
его размещением и наличием или отсутствием явного подключения к земле. 

Для CPW и других структур с несколькими заземлёнными плоскостями 
нужно всегда добавлять отрицательные клеммы порта. На рис. 9 показана 
корректная установка порта CPW. 

Рис. 9
Волноводные порты. 

Волноводные порты возбуждают самый низкий тип волноводных колебаний. Эти порты 
определяются на внешних сторонах граничных плоскостей, где порт не связан с земляной плоскостью. 
Любая другая конфигурация порта обрабатывается как сосредоточенный порт. Эти порты не возбуждают 
паразитных колебаний и поэтому не требуют исключения неоднородностей в отличие от сосредоточенных 
портов. 

Волноводный порт возбуждает поле на всей плоскости порта. При установке волноводных портов 
граничные поверхности должны быть достаточно далеко от ЕМ структуры, чтобы избежать влияния форм 
ЕМ структуры на возбуждение волноводных колебаний. Можно определить любое количество волноводных 
портов на одной  плоскости и Analyst вычисляет результаты для каждого порта независимо. Можно также 
определить дифференциальные пары волноводных портов, определённых на одной плоскости, определяя 
один положительный порт и один или несколько отрицательных с одинаковыми номерами. 

Сосредоточенные порты. 
Сосредоточенные порты возбуждают ЕМ структуру подключением источника напряжения к двум 

клеммам. Такой порт должен иметь явное или неявное подключение к земле. Дифференциальные порты 
могут иметь одну положительную и несколько отрицательных клемм. Кроме того, можно определить любое 
количество дифференциальных пар с одинаковым номером портов. Все порты должны быть определены на 
электрических проводниках, иначе анализ не выполняется с выдачей ошибки. 

Исключение неоднородностей портов не поддерживается в Analyst. Однако, чтобы сравнить 
результаты в AXIEM и Analyst, нужно исключить неоднородности портов в AXIEM. Из-за различных 
методов анализа, паразитные элементы портов намного меньше влияют на результаты анализа в Analyst, чем 
в AXIEM. 

Понятие импеданса порта. 
Если дважды щёлкнуть по порту в ЕМ структуре, откроется окно Port Attributes, в котором можно 

редактировать свойства порта. Можно изменить импеданс порта и уровень мощности. Это влияет только на 
определение тока и поля непосредственно в ЕМ структуре и не влияет на определение S-параметров. При 
определении S-параметров сопротивление портов всегда считается 50 Ом. Если нужно выполнить анализ с 
другим сопротивлением портов, нужно создать схему, включить в неё ЕМ структуру в качестве подсхемы и 
определить нужное сопротивление портов. 

Работа с иерархией. 
Создание иерархической ЕМ структуры часто упрощает проект. Когда ЕМ структура используется в 

качестве подсхемы, она автоматически не анализируется при выборе Simulate>Analyze. Вместо этого ЕМ 
подсхема анализируется только если она является источником единицы измерения или аннотации. 

Следующий пример иллюстрирует, как перекрывающиеся материалы разделяются в иерархической 
структуре, когда есть слой воздуха, определённый в подсхеме. 

Рис. 11 Рис. 10 
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На рис. 10 показано двухмерное отображение дочерней структуры с двумя диэлектрическими 
слоями. На рис. 11 - трёхмерное отображение этой же структуры. 

Верхний слой - воздух, который по умолчанию не отображается в трёхмерном отображении,  
нижний слой - диэлектрик. 

На рис.12 показана структура, когда дочерняя структура добавлена в родительскую структуру с 
диэлектрической постоянной er=10. Нормы перекрывающихся материалов привели к тому, будто 

диэлектрический слой подсхемы вытеснил диэлектрик основной схемы за исключением слоя воздуха даже 
при том, что диэлектрическая постоянная слоя диэлектрика подсхемы ниже. Слой подсхемы вытеснил 
(заменил) материал основной схемы - потому что имеет более высокий приоритет. Но воздушный слой 
подсхемы проигнорирован и занят диэлектриком основной структуры. 

Рис. 13 Рис. 12 

На рис. 13 показана та же дочерняя структура, но слой воздуха включён (экструдирован) в 
структуру для включения его в процесс анализа. Трёхмерное отображение такое же, потому что воздух не 

отображается. Поскольку здесь воздушный зазор включён в 
процесс анализа, он сохраняется и при добавлении этой структуры 
в качестве подсхемы (рис. 14). 

Открытые типы граничных условий не применимы к 
подсхемам, которые помещаются в схему. Открытые типы 
граничных условий включают Approx Open, Perfectly Matched 
Layer (PML), и Perfect Magnetic Conductor (PMC). Все другие 
поверхности раздела сохраняются, когда подсхема помещается в 
родительскую схему. Например, можно определить Perfect 
Electric Conductor (PEC) для нижней стенки корпуса и боковых 

стенок в подсхеме. При размещении такой структуры в качестве подсхемы, земляная плоскость и боковые 
стенки сохраняются. 

Рис. 14 

Опции для выполнения анализа в Analyst. 

Опции сетки. 
Можно определять различные опции встраивания сетки для анализа в Analyst. Эти опции 

воздействуют только на начальную сетку, сгенерированную для использования в процессе адаптивной 
доводки сетки (Adaptive Mesh Refinement - AMR), поэтому установки по умолчанию можно оставить. 
Однако иногда установки по умолчанию могут быть изменены, например, чтобы установить более тонкую 
начальную сетку. В этой версии установку начальной сетки можно выполнить только глобально. 

Чтобы получить доступ к опциям сетки, щёлкните правой кнопкой мышки по имени ЕМ структуры 
в окне просмотра проекта и выберите Options, чтобы открыть диалоговое окно Options, затем откройте 
вкладку Mesh. Существуют следующие опции: 

Model As Zero Thickness - Analyst поддерживает формы нулевой толщины, где толщина материала 
определена как 0.0. Чтобы сравнивать результаты анализа в AXIEM и Analyst, гарантируйте, что оба 
решающих устройства используют те же самые параметры толщины проводника. Обратите внимание, что 
по умолчанию Off для Analyst и On для AXIEM. 

Size Type - Определяет, задан ли размер ячейки сетки как относительный или как абсолютный 
размер. 

Relative Size - Максимальная длина стороны ячейки сетки относительно 1/10-ой диагонали 
прямоугольного корпуса, ограничивающего структуру. 

Absolute Size - Максимальный размер ячейки сетки, определённый в действующих единицах длины. 
Чтобы создать более тонкую сетку, нужно уменьшить это значение. 

Curvature Refinement Level - Контролирует точность, с которой сетка представляет изогнутые 
поверхности и стороны. Возможные значения - между 0.0 и 1.0. Меньшие значения представляют более 
точно изогнутые поверхности и стороны. 

Anisotropic Curvature Refinement - Может существенно уменьшить вычисления в неоднородной 
структуре, содержащей длинные цилиндры малого диаметра, например, проволочные соединения (bond 
wires). 

Relative Minimum Curvature Size - Определяет минимальное допустимое значение параметра 
кривизны для наименьшего элемента, который будет создан. 
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Enable Small Feature Suppression - Может помочь облегчить проблемы со сложной и/или 
импортированной геометрией. 

Absolute Small Feature Suppression Tolerance - Определяет допустимое отклонение длины. 
Рекомендуемое значение 0.0. Малое значение уменьшает шанс повреждения сетки, слишком большое 
значение может значительно изменить геометрию. 

Enable Local Meshing Controls - Если выбрано, соединение определяется свойствами геометрии 
(корпуса, лица или стороны). 

Опции планировщика заданий. 
Планировщик заданий (Job Scheduler) в Analyst может 

направить выполнение анализа на один или несколько 
процессоров или ядер. Чтобы получить доступ к опциям 
планировщика заданий, щёлкните правой кнопкой мышки по 
имени ЕМ структуры в левом окне просмотра проекта и 
выберите Options (рис. 15). Если щёлкнуть левой кнопкой 
мышки по какой либо опции, то в нижней части окна будет 
описание действия этой опции. Чтобы включить опцию в 
проект, нажмите OK. 

Рис. 15  

Опции решающего устройства. 
Можно выбрать различные опции решающего устройства для ЕМ структуры в Analyst. Как правило 

достаточно использовать установки по умолчанию, но их можно изменить. Чтобы получить доступ к опциям 
решающего устройства, щёлкните правой кнопкой мышки по имени ЕМ структуры в левом окне просмотра 
проекта и выберите Options, чтобы открыть диалоговое окно Options, затем откройте вкладку Analyst. 
Следующие опции доступны: 

 Field Output Frequency - Определяет, для каких частот следует выполнить расчёт поля. Если эта 
опция не определена и потребуется посмотреть поле, анализ придётся повторить с установленной 
опцией. 

 Solve Type - Можно выбрать Full, чтобы выполнить полный анализ или Ports Only, чтобы 
выполнить анализ только портов. 

 Sweep Type - можно выбрать Automatic, Discrete, GAWE  (быстрое свиппирование частоты). 
 Basis Set - Контролирует уровень интерполяции для полей, который используется на ячейке сетки. 
 Minimum Solved Frequency - Самая низкая частота, для которой анализ выполняется методом 

конечных элементов. Ниже этой частоты вычислитель использует экстраполяцию. 
 Solve Inside Conductors - По умолчанию моделирующая программа использует эквивалентные 

граничные условия полного сопротивления на всех электрических проводниках, чтобы выполнить 
анализ быстрее и использовать меньше ресурсов. Когда моделируется глубина скин-слоя, чтобы 
учесть потери, измените это значение на Always. Эта установка приводит к увеличенному 
использованию ресурсов и часто очень быстро развивает сетку, чтобы захватить скин-слой. 

 Extrapolate Toward DC - Эта опция управляет поведением вычислителя ниже Minimum Solved 
Frequency. Если выбрано Cubic Polynomial Fit, то для экстраполяции на более низких частотах 
используется кубический полином. Если выбрано None, то на частотах ниже минимальной 
частоты значения остаются равными значению на допустимой низкой частоте (по умолчанию 10 
МГц). 

 Remote Simulation for Refine Solution - Выбор этой опции позволяет выполнять анализ на 
нескольких компьютерах. Чтобы иметь такую возможность нужно иметь специальную лицензию. 

Опции адаптивного усовершенствования сетки. 
Analyst использует алгоритм адаптивного усовершенствования сетки (Adaptive Mesh Refinement - 

AMR). который выполняет анализ с многократным изменением сетки, делая её более тонкой для каждого 
очередного вычисления. Сетка усовершенствуется, чтобы определить, какая область тока вносит большую 
ошибку в конечный результат. Процесс AMR продолжается, пока изменения в сходимости меньше, чем 
определённый пользователем допуск, или максимальное количество итераций достигнуто. Т.к. количество 
итераций влияет на точность анализа и на время, опции, которые контролируют сходимость (особенно 
допуск сходимости), являются одними из самых важных для решающего устройства. Чтобы определить 
опции, щёлкните по имени ЕМ структуры правой кнопкой мышки, выберите Options и откройте вкладку 
Analyst. Эти опции могут быть установлены только для портов (Ports only) или для полного решения (Full 
Solves). 
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 Target Mesh Growth Fraction - Контролирует, как быстро увеличивается количество ячеек сетки в 
зависимости от длины волны и глубины скин-слоя. Значение 0.2 указывает, что количество ячеек 
увеличивается не более, чем на 20% от одной итерации к другой. Target Mesh Growth Fraction 
универсальна для выполнения анализа, но для портов можно установить и другие опции. 



 Maximum Iterations - Максимальное количество итераций, разрешенных на каждом этапе 
анализа. 

 Frequency Modifier - По умолчанию процесс AMR выполняется только на одной частоте. Анализ 
на остальных частотах выполняется после окончания процесса AMR, используя его результаты. 

Например, если для анализа заданы частоты 1, 2, 
3, 4, и 5 ГГц, и Frequency Modifier (модификатор 
частоты) установлен в Mid (средина), то AMR 
выполняется на частоте 3 ГГц. Можно выбрать 
All (все), если хотите использовать все частоты, 
но это значительно замедляет время аналтза. 
Можно определить любую частоту, выбрав 
Custom. 
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 Result Convergence - Определяет критерий 
прекращения выполнения процесса AMR. 
Значение 0.01 указывает, что анализ будет 
прекращён, если отличие результатов очередной 
итерации от результатов предыдущей меньше 
1%. 

Нужно быть внимательным при выборе частоты 
для AMR. Если моделируется фильтр и частота для AMR 
установлена вне полосы пропускания, то результаты 
анализа будут не точными. На такой частоте сигнал через 

фильтр не проходит и процесс AMR закончится быстро, т.к. разница в результатах между двумя итерациями 
будет маленькой. При этом ячейки сетки останутся крупными и точность анализа будет грубой. Например, 

моделируется фильтр с центральной частотой 4.4 ГГц и шириной полосы пропускания около 10%. Разница в 
вычислении обратных потерь на частотах 
4.4 ГГц и 5.0 ГГц показана на рис. 16. 

Рис. 16 

Рис. 17 Рис. 18 

На рис. 17 показана встраиваемая 
сетка при частоте AMR, равной 4.4 ГГц, а 
на рис 18 - на частоте 5 ГГц. Видно, что на 
частоте 5 ГГц сетка более крупная и не 
обеспечивает хорошей точности результата 
анализа. 

После того как выполнение анализа 
закончено можно щёлкнуть по имени ЕМ 
структуры в левом окне просмотра проекта 
правой кнопкой мышки и выбрать Refine 
Solution (уточнить решение) как показано 
на рис. 19. Если нет никакого изменения в 
опции сходимости эта команда выполняет 
ещё одну или больше итераций чтобы 
уточнить AMR. 
 

Рис. 19 



Выполнение анализа в Analyst. 

Процесс адаптивного усовершенствования сетки. 
Анализ в Analyst выполняется так же, как и в AWRDE. Однако, в отличие от AXIEM, выполняется 

процесс адаптивного усовершенствования сетки (AMR). Результаты процесса AMR возвращаются в 
AWRDE, что позволяет контролировать процесс AMR. Процесс AMR выполняется в три фазы следующим 
образом. 
Фаза 1. AMR только портов (Ports Only). 

Этот шаг усовершенствует сетку, пока не будет получено схождение решения порта. Это важно 
только для волноводных портов. Для сосредоточенных портов эта фаза выполняется и сходится немедленно. 
Критерием сходимости является или постоянная распространения Kz, или характеристический импеданс Zc, 
в зависимости от доступности. Фаза 1 (Ports Only) включает опции, влияющие на этот шаг. Обычно 
установки по умолчанию достаточны. 
Фаза 2. Полное решение AMR (Full Solve). 

После окончания Ports Only делается переход в фазу Full Solve. Здесь критерий сходимости 
основан на матрице рассеяния. Этот критерий вычисляет максимальное изменение в величине S (на всех 
частотах и для всех элементов S). Фаза 2 имеет опции, влияющие на выполнение этой фазы. Фаза 2 делает 
оценку памяти, необходимую для следующего шага. Если памяти недостаточно, выполнение фазы 2 
прекращается с выдачей соответствующего сообщения и делается переход к следующей фазе. При этом 
анализ можно продолжить, но нет гарантии, что результат сойдётся и будет правильным. 
Фаза 3. Окончательное решение (Final Solve). 

После окончания фазы Full Solve готовится переход к анализу на всех частотах, используя 
полученную встроенную сетку. Среди опций решающего устройства имеются опции, влияющие на эту фазу, 
хотя многие из этих опций используются в течение процесса AMR. 

Окно статуса. 
В окне статуса отображаются все сообщения о ходе выполнения анализа. Некоторые сообщения 

показаны также в Output log, описанном ниже. Нужно просматривать все предупреждающие сообщения, 
чтобы определить причину неисправности и устранить её. 

Output log (журнал регистрации результатов). 
Журнал регистрации результатов показывает детали текущего состояния выполнения анализа. 

Большинство информации о выполнении AMR показано в таблице, в которой содержится краткий обзор 
процесса и текущее состояние во время выполнения AMR. На рис. 20 пример такой таблицы. 

Эта таблица представляет промежуточный результат выполняющегося анализа. В таблицу включена 
следующая информация: 

Рис. 20

 Iteration: Номер итерации и тип. Текст указывает, была ли каждая итерация Ports Only solve или 
Full solve. 

 Elements: Количество элементов, использованных для нахождения решения. В зависимости от 
конфигурации и материалов, это количество может быть меньше, чем общее количество 
элементов в системе. Элементы в металлах или в электрически изолированных областях 
конфигурации не влияют на конечное решение и в результате не используются в вычислении 
методом конечных элементов. Поэтому количество элементов, указанное в таблице может быть 
меньше или равно количеству элементов, сгенерированных в ЕМ структуре. 

 Delta Zc/Kz (0.01): Или характеристическое полное сопротивление порта (Zc), или постоянная 
распространения (Kz) используется как мера сходимости в вычислении порта, в зависимости от 
возможности использования. Если решение сходится, отношение Zc/Kz уменьшается. Значение в 
скобках (здесь 0.01) указывает предел для сходимости. Звёздочка в красном кругу показывает 
значение, при котором сходимость достигнута. 

 Delta S (0.001): Для критерия сходимости используются S-параметры, поскольку выполняется 
фаза Full solve. Для Ports Only эти вычисления не делаются, поэтому значения в этой колонке n/a. 
Значение в круглых скобках (здесь 0.001) указывает предел для сходимости. Когда предел 
сходимости достигнут, рядом со значением появляется звёздочка. В этом примере предел ещё не 
достигнут. 
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 Time (min): Время от начала выполнения анализа в минутах. 
 Peak Memory (MB): Указывает максимальный объём памяти в мегабайтах. В скобках указан 

процент от имеющейся памяти. 
 No. of VMs: Количество виртуальных машин (VMs), которые использует решающее устройство. 

Это значение зависит от параметров анализа и может изменяться при переходе от одной итерации 
к следующей. 

В каждой новой итерации, результаты предыдущей итерации используются, чтобы 
усовершенствовать сетку. Детали изменений сетки представлены после заполнения таблицы, показывая 

количество улучшенных или более грубых элементов. 
Указывается полное количество элементов, включая не 
участвующие при выполнении анализа. 

После того, как последовательность AMR 
выполнена и решающее устройство выполняет 
окончательный анализ, Output log показывает 
выполнение этого анализа. Содержание окна 

отображения процесса анализа зависит от типа свиппирования частоты. Для дискретных частот 
отображается каждая частота. Для быстрого свиппирования частоты (GAWE или MGAWE) отображается 
общее количество частот (nf в Output log) и номер частоты, на которой выполнялся анализ (epfi в Output 
log). Пример при быстром свиппировании частоты показа на рис. 21. 

Рис. 21 

Решающее устройство сообщает о количестве виртуальных машин и затем начинает анализ.  В этом 
примере определены 31 частотная точка для анализа. Первый шаг GAWE расширяется вокруг центральной 
частоты с индексом epfi=16. Это также расширяется вокруг конечных точек, но решение от первого 
расширения достаточно точно, таким образом от следствий расширения вокруг конечных точек 
отказываются. Решающее устройство тогда сообщает о результатах GAWE: решение точно описано на всех 
31 частотах с единственной точкой расширения; первое расширение указывает на epfi=16. 

Когда анализ сходится, отображается звёздочка рядом с показателем сходимости. В нашем примере 
Delta S уменьшается довольно медленно и можно ожидать ещё много итераций, пока решение сойдётся. 

Просмотр результатов анализа. 

Наборы данных в Analyst. 
Наборы данных в Analyst в основном идентичны наборам данных 

анализа в AXIEM. Отличаются тем, что содержат данные, полученные при 
выполнении AMR. На рис. 22 пример набора данных когда анализ 
выполняется или закончен. 
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Значки P в наборе данных указывают Port Only последовательности 
AMR. После окончания анализа можно обновить данные каждого поднабора 
данных, чтобы посмотреть график данных, так же как сетку и аннотацию 
поля в трёхмерном отображении. 

Замечание. Поднаборы данных никогда не сохраняются в проекте, 
потому что могут требовать значительного места на диске, и обычно 
необходимы непосредственно после окончания анализа, чтобы видеть её 
последовательность. Они доступны, если закрыть и затем открыть проект, но 

они больше не будут доступны, если сохранить проект и переместить его в новое место. 
Рис. 22 

Просмотр сетки. 
Структуру сетки можно просмотреть в трёхмерном отображении 

ЕМ структуры. При открытом активном окне трёхмерного отображения 

ЕМ структуры щёлкните по значку Show 3D Mesh  на панели 
инструментов. Если анализ ещё не выполнялся, будет показана 
первоначальная сетка. 

Аннотация MESH_3D добавляется под именем ЕМ структуры в 
левом окне просмотра проекта. Дважды щёлкните по аннотации, чтобы 
посмотреть доступные опции. Щёлкните по кнопке Show 3D Mesh снова, 
чтобы отключить отображение сетки. 

Если во время выполнения анализа открыто окно трёхмерного 
отображения сетки. то можно видеть, как изменяется сетка при 
выполнении анализа. После окончания анализа отображается последняя 

сетка, встроенная в ЕМ структуру. 

Рис. 23

Плоскости вырезки (Cut Planes) - полезное приспособление для просмотра сетки (рис. 23). Одна 
сторона плоскости показывает сетку, в то время как другая сторона это не делает, и размещение плоскости 



легко переместить. Чтобы установить плоскость вырезки, щёлкните по значку Use Cut Plane  на панели 
инструментов. Плоскость вырезки подчиняется тем же правилам, что и в AXIEM. 

Просмотр полей. 
Следующие трёхмерные аннотации можно добавить к ЕМ структуре в Analyst: 

 EM_FIELD_CUT - Щёлкните кнопку Show Currents/Fields  на панели инструментов, чтобы 
добавить эту аннотацию. Её можно использовать для просмотра поля на плоскостях вырезки. 

 EM_FIELD_CARPET - Позволяет просматривать ковровые графики базового поля (field-based). 
 EM_FIELD_CONT - Позволяет создавать контурные графики поверхности. 
 EM_FIELD_VECT - Позволяет просматривать векторные поля. 

Пример моделирование ЕМ структуры с проволочными перемычками. 
Этот пример включает следующие основные шаги: 

1. Преобразование AXIEM структуры в структуру Analyst. 
2. Конфигурирование портов и корпуса. 
3. Просмотр начальной сетки. 
4. Выполнение анализа. 
5. Создание иерархической структуры. 
6. Добавление 3-х мерной параметризированной проволочной перемычки (ячейки pcells - bond wire). 
7. Использование диэлектрической вставки. 
8. Выполнение анализа всей структуры. 
9. Просмотр результатов и Е-полей. 
10. Упрощение структуры, чтобы анализировать только проволочные перемычки. 

Открытие существующего проекта. 
1. Загрузите AWRDE. 
2. Выберите в меню File>Open Example. В нижней строке ввода щёлкните мышкой, чтобы 

освободить её, и наберите Analyst_Basic_Start. В списке останется только имя проекта 
Analyst_Basic_Start.emp. Дважды щёлкните по этому имени, чтобы открыть проект. 

3. Выберите в меню File>Save Project As. 
4. Выберите рабочий каталог и сохраните в нём проект с именем Analyst_GS. 
5. Выберите в меню Options>Project Options и на вкладке Global Units отметьте GHz для частоты и 

um для единиц измерения длины. 

Преобразование структуры AXIEM в Analyst. 
Чтобы преобразовать структуру AXIEM в Analyst: 

1. Выполните анализ, чтобы убедиться, что анализ структуры AXIEM_Line выполняется. После 
окончания анализа посмотрите результаты на 
диаграмме Смита S Parameters. 
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2. Щёлкните правой кнопкой по имени ЕМ структуры 
в левом окне проекта и выберите Duplicate EM 
Structure. Будет создана копия ЕМ структуры с 
именем AXIEM_Line_1. 

3. Щёлкните правой кнопкой мышки по имени 
созданной копии ЕМ структуры в левом окне 
просмотра проекта, выберите Rename EM Structure 
и переименуйте её в Analyst_Line. 

4. Щёлкните правой кнопкой мышки по имении 
структуры Analyst_Line в левом окне проекта и 
выберите Set Simulator. В открывшемся окне 

отметьте AWR Analyst 3D EM и нажмите OK. Полученная структура показана на рис. 24. 
Рис. 24

5. Analyst требует определить граничные условия не только для верхней и нижней поверхностей, но 
и для боковых. Можно 
редактировать граничные 
условия для каждой 
поверхности раздела или 
добавить новую 
граничную форму для 
замены формы, созданной 
по умолчанию. 

Чтобы начертить новую 
форму поверхностей раздела: 

Рис. 18.25 Рис. 18.26 



1. При активном окне Analyst_Line выберите в меню Draw>Rectangle или щёлкните по значку 
Rectangle на панели инструментов. 

2. Поместите курсор мышки в окно ЕМ структуры и нажмите клавишу Tab. Откроется окно Enter 
Coordinates. В поле x введите 0, в поле y введите -200, нажмите OK (рис. 25). 

3. Снова нажмите клавишу Tab и в новом открывшемся окне Enter Coordinates в поле dx введите 
800, в поле dy введите 470, нажмите OK (рис. 26). Топология будет выглядеть, как показано на 
рис.27. Новая форма будет автоматически выделена. 
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4. Выберите в меню Draw>Create Simulation Boundary, чтобы превратить новую форму в форму 

граничных поверхностей раздела. Или щёлкните по значку Create Simulation Boundary  на 
панели инструментов. 

Рис. 28 Рис 27

5. Из двух граничных форм (рис. 28) выделите первоначальную, щёлкнув по ней мышкой, и нажмите 
клавишу Delete. 

6. Щёлкните по оставшейся граничной форме левой кнопкой мышки, затем щелкните правой 
кнопкой и выберите Shape Properties, чтобы открыть диалоговое окно Properties (рис. 29). 
Убедитесь, что граничные условия соответствуют этому рисунку. 

Топология будет выглядеть, как показано на рис. 30. 

Можно просмотреть ЕМ структуру в трёхмерном отображении, чтобы убедиться, что граничные 
условия выбраны правильно: 

Рис.30
Рис. 29 

1. Откройте трёхмерное отображение ЕМ структуры, выбрав в меню View>View 3D EM Layout или 
щелкнув по значку View EM 3D Layout на панели инструментов. 

2. Щёлкните по значку Show Boundary Conditions  на панели инструментов. Топология будет 
выглядеть, как показано на рис. 31. 

Рис. 32
Рис. 33 

Рис. 31 



3. Откройте окно менеджера топологии Layout в левом окна просмотра проекта и щёлкните по 
строке Visibility By Material/Boundary. Здесь можно включать/отключать видимость материалов 
(рис. 32). Например, если выключить материал Approx Open, то структура будет выглядеть, как 
показано на рис. 33. 

4. Щёлкните по значку Show Boundary Conditions на панели инструментов, чтобы отключить  
трёхмерное отображение граничных условий. 

Analyst поддерживает волноводные порты и сосредоточенные порты. Предпочтительнее 
волноводные порты, которые должны быть подключены к форме, касающейся поверхности раздела. 
Сосредоточенные порты можно прикрепить в любом месте. 

Чтобы подключить волноводные порты: 
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1. В активном окне двухмерного отображения щёлкните по порту левой кнопкой мышки, затем 
правой и выберите Shape Properties. 

Рис. 35 

Рис. 34 

2. В открывшемся окне Properties (рис. 34) на вкладке Port Attributes в поле Explicit Ground 
Reference введите None (Wave Port or Differential) и нажмите OK. 

3. Аналогично измените свойства второго порта. Топология будет выглядеть, как на рис. 35. 

18.11.3. Выполнение анализа. 
Структура в Analyst готова для выполнения анализа в диапазоне от 0.1 до 10 ГГц с шагом 1 ГГц. 
Перед выполнением анализа можно просмотреть встраивание сетки в 3-х мерном отображении 

структуры. Это только начальная сетка для выполнения анализа. Каждый шаг адаптивного 
усовершенствования сетки (Adaptive Mesh Refinement - AMR) обновляет встраиваемую сетку. 

Чтобы просмотреть встраиваемую сетку: 
1. Откройте 3-х мерное отображение структуры, выбрав в меню View>View 3D EM Layout или 

щёлкнув по значку View EM 3D Layout на панели инструментов. 

Рис. 36 Рис.  37 



2. Щёлкните по значку Show 3D Mesh  на панели инструментов. Топология со встроенной 
первоначальной сеткой показана на рис. 36. Отображение встраиваемой сетки в воздухе 
отключено по умолчанию. Его видимость можно включить в менеджере топологии в Visibility By 
Material/Boundary и тогда структура будет отображаться, как показано на рис. 37. 

Чтобы выполнить анализ: 
1. Выберете в меню Simulate>Analyze или щёлкните по значку Analyze на панели инструментов. 

Рис. 38 

2. В диалоговом окне Simulation отображается ход выполнения анализа (рис. 38). Если щёлкнуть по 

значку  напротив Output log, то будут отображаться детали выполнения анализа. Здесь можно 
видеть работу AMR, схождение анализа, время выполнения и пр. (рис. 39). 

Рис. 39 

3. Если при выполнении анализа отрыто окно 3-х мерного отображения структуры со встроенной 
сеткой, то можно наблюдать, как изменяется сетка при выполнении анализа. 

Заметим, что во время выполнения анализа можно редактировать ЕМ структуру. 
Можно использовать плоскости вырезки для просмотра сетки, граничных условий и Е-поля в  

трёхмерном отображении. 
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Чтобы использовать плоскости вырезки: 
Рис. 40 Рис. 41 

1. Откройте трёхмерное отображение ЕМ структуры, выбрав в меню View>View 3D EM Layout или 
щёлкнув по значку View EM 3D Layout на панели инструментов. 

2. Щёлкните по кнопке Use Cut Plane на панели инструментов. Часть структуры до плоскости 
вырезки будет удалена (рис. 40). 

3. Установив курсор на плоскость вырезки и нажав левую кнопку мышки, можно перемещать 
плоскость вырезки. Установив курсор на конец стрелки, которая видна на плоскости вырезки, и 
нажав левую кнопку мышки, можно изменять угол наклона плоскости вырезки. Нажимая клавиши 
x, y или z можно менять ориентацию плоскости вырезки относительно осей. 

Чтобы просмотреть результаты анализа: 



1. В левом окне просмотра проекта щёлкните правой кнопкой мышки по имени измеряемой 
величины AXIEM_Line:S(2,1) в графике S Parameters и выберите Duplicate. 

2. В открывшемся окне в поле Data Source Name введите Analyst_Line и нажмите OK. 
3. Сделайте тоже самое для измеряемой величины AXIEM_Line:S(1,1). 
4. Чтобы отобразить графики, щёлкните по значку Analyze на панели инструментов. график будет 

выглядеть, как показано на рис. 41.. 

Создание иерархической структуры. 
При использовании иерархии, которую можно использовать в Analyst и в AWRDE, можно 

упростить создание слоёв диэлектриков. Каждая ЕМ структура имеет собственный набор диэлектриков. При 
объединении этих структур в иерархию нужно определить соответствующее размещение объединяемых 
структур в направлении Z и AWRDE правильно сконфигурирует слои диэлектриков. Это свойство даёт ряд 
преимуществ: 

 Не нужно создавть комплект диэлектрических слоёв до создания иерархической структуры. 
 Можно легко добавить больше диэлектрических слоёв на более поздних стадиях иерархической 

структуры. 
Чтобы создавать новую ЕМ структуру в Analyst: 

1. Щёлкните правой кнопкой по EM Structures в левом окне просмотра проекта и выберите New EM 
Structure. Альтернативно можно выбрать в меню Project>Add EM Structure>New EM Structure 
или щёлкнуть по значку Add New EM Structure на панели инструментов. 

2. В диалоговом окне New EM Structure (рис.18.42) введите имя структуры PCB, выберите 
симулятор AWR Analyst 3D EM, отметьте From Stackup в области Initialization Options, введите 
PCB в поле Stackup и нажмите Create. В этом примере элемент Stackup уже определён и 
находится в окне Global definitions. При желании этот элемент можно открыть и посмотреть 
определённые слои и материалы. 

Рис. 43 Рис.  42 

3. В левом окне просмотра проекта дважды щёлкните по 
Enclosure под именем ЕМ структуры PCB. В открывшемся 
окне для Grid_X и Grid_Y введите 50 для определения 
встраиваемой сетки (что не имеет влияния на выполнение 
анализа в Analyst). По умолчанию при создании ЕМ 
структуры создаётся квадратная форма поверхности 
раздела. 
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Чтобы конфигурировать поверхность раздела: 
1. Сделайте активным окно двухмерного отображения 

созданной ЕМ структуры. 

Рис. 44 

2. Дважды щёлкните мышкой по граничной форме, чтобы ввести режим редактирования. Небольшие 
ромбики/квадратики появятся на срединах сторон и по углам (рис. 43). 

3. Установите курсор на верхний правый угол формы, нажмите левую кнопку мышки и клавишу 
Tab. В открывшемся окне ввода координат (рис. 44) снимите отметку Rel, в поля x и y введите 
5000, нажмите OK. 

4. Щёлкните правой кнопкой в окне двухмерного отображения ЕМ структуры и выберете View All, 
чтобы видеть всю граничную форму. 
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5. При выделенной граничной форме щёлкните по ней правой кнопкой мышки и выберите Shape 
Properties, чтобы убедиться, что параметры граничной формы соответствуют показанным на рис. 
45. Нажмите OK. 

Рис. 47Рис. 46

Рис. 45 

6. Щёлкните правой кнопкой мышки по имени PCB ЕМ структуры в левом окне просмотра проекта 
и выберите Options. Откройте вкладку Frequencies. Обратите внимание что частотный диапазон 
для выполнения анализа уже установлен. На вкладках Mesh и Analyst при желании можно 
изменить опции сетки и решающего устройства Analyst. 

Теперь можно создавать иерархическую структуру, добавив Analyst_Line в PCB: 
1. В левом окне проекта откройте менеджер топологии. 

2. В поле EM Layer введите номер слоя 2 для начального 
размещения Z подсхемы (рис. 18.46). 

3. При активном окне топологии ЕМ структуры PCB 
выберите в меню Draw>Add Subcircuit. В 
открывшемся окне Add Subcircuit (рис. 47) щёлкните 
по Analyst_Line и затем нажмите OK. 

4. Поместите курсор мышки (на нём отображаются 
координаты положения курсора) и нажмите клавишу 
Tab. В открывшемся окне ввода координат (рис. 48) 

снимите отметку Rel, в поле x введите 2100, в поле y введите 2465 и нажмите OK. Подсхема будет 
помещена в центр поверхности раздела. 

Рис. 48 

Рис. 51
Рис. 49

5. Щёлкните по значку View EM 3D Layout на панели инструментов, чтобы просмотреть 3-х мерное 
отображение структуры (рис. 49). Заметьте, что топология линии находится на вершине слоя, 
который является подложкой в новой структуре. 

Рис. 50



6. Можно легко изменить Z-положение подсхемы. Например, чтобы переместить подсхему на 
основание, в двухмерном отображении щёлкните по ней левой кнопкой мышки, затем правой и 
выберите Shape Properties. В открытом окне (рис. 50) в области Z Position в поле EM Layer 
введите Bottom boundary. Структура будет выглядеть, как показано на рис. 51. 

7. Восстановите положение подсхемы на втором слое. Для этого выберите в меню Edit>Undo или 
щёлкните по значку Undo на панели инструментов. 

Теперь можно создать заземляющие перемычки для подсхемы: 
1. При активном окне ЕМ структуры PCB откройте в левом окне проекта менеджер топологии и 

щёлкните по строке Drawing Layers, чтобы видеть доступные слои черчения (рис. 52). 
2. В Drawing Layers 

щёлкните мышкой по 
прямоугольнику в 
строке Copper, 
чтобы выбрать этот 
слой для черчения. 
Щёлкните по значку 

Rectangle на панели инструментов, поместите курсор в окно ЕМ структуры и нажмите клавишу 
Tab. В открывшемся окне Enter Coordinates снимите отметку в Rel, в поле x введите 2000, в поле 
y введите 2250 (рис. 53) и нажмите OK. Снова нажмите клавишу Tab. Отметьте Rel, в поле dx 
введите 1000, в поле dy введите 500 (рис. 54) и нажмите OK. Форма под линией (т.е. на слое 2) 
будет отображаться, как показано на рис. 55). 

Рис. 54Рис. 53 Рис. 52 

3. В Drawing Layers выберите слой Via и выберите в меню Draw>Ellipse или щёлкните по значку 
Ellipse на панели инструментов. Создайте перемычку 100х100 и поместите её как показано на рис. 
56. 
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4. Скопируйте созданную перемычку и добавьте ещё три копии перемычек, как показано на рис. 57. 
5. В Drawing Layers выберите слой Copper. Щёлкните по значку Rectangle на панели инструментов. 

Поместите курсор в окно 
ЕМ структуры и нажмите 
клавишу Tab. В 
открывшемся окне Enter 
Coordinates снимите 

отметку в Rel, в поле x 
введите 0, в поле y 
введите 2250 (рис. 58) и 
нажмите OK. Снова 
нажмите клавишу Tab. 
Отметьте Rel, в поле dx 

введите 1850, в поле dy введите 500 (рис. 59) и 
нажмите OK. Форма под линией (т.е. на слое 2) 
будет отображаться, как показано на рис. 60). 

6. Скопируйте вновь созданный проводник и 
поместите его на правый край ЕМ структуры, как 
показано на рис. 61. 

7. Щёлкните по левому проводнику мышкой чтобы 
выделить его. 

8. Выберите в меню Draw>Add Edge Port или 
щёлкните по значку Edge Port на панели Рис. 63 

Рис.55 Рис. 56 Рис.57

Рис. 58 Рис. 59 Рис. 60 

Рис. 61 

Рис. 62 



инструментов. установите порт на левый край выделенного проводника. Аналогично установите 
порт на правый край последнего проводника (рис. 62). 

9. Порты установятся с опцией Connect to lower. Если это не так, дважды щёлкните по порту и в 
открывшемся окне в поле Explicit Ground Reference введите Connect to lower. 

Трёхмерное отображение ЕМ структуры показано на рис. 63. Таким образом, в этом примере 
установлены сосредоточенные порты. Если в Explicit Ground Reference ввести None (Wave Port or 
Differential), будут установлены волноводные порты. Результаты анализа с волноводными портами будут 
более точными, но время выполнения анализа будет больше. 

Добавление 3-х мерных параметризированных ячеек (проволочных 
перемычек. 

Чтобы добавить проволочные перемычки: 
1. При активном окне с двухмерным отображением ЕМ структуры PCB щёлкните по значку Add 

Bondwire  на панели инструментов, чтобы добавить трёхмерную проволочную перемычку к 
топологии. 

2. Поместите проволочную перемычку, как показано на рис. 64. Как подсхема, проволочная 
перемычка помещается на слой, установленный в EM layer (в нашем случае слой 2). 

3. Дважды щёлкните по перемычке мышкой. На её краях появятся небольшие ромбики. Установите 

курсор на ромбик в правом конце перемычки так, чтобы он отображался в виде двойной стрелки. 
Нажмите левую кнопку мышки и 
продлите перемычку вправо на 100 
um, чтобы соединить её с выходным 
проводником. Трёхмерное 
отображение соединения двух 
проводников  проволочной 
перемычкой будет выглядеть, как 
показано на рис. 65. 

Рис. 64 Рис. 65 

4. Чтобы конфигурировать созданную 
перемычку, в двухмерном 
отображении щёлкните по ней левой 
кнопкой мышки, затем правой и 
выберите Element Properties. 
Откроется окно свойств перемычки 
(рис. 66). Установите параметры 
перемычки, которые указаны на этом 
рисунке, нажмите OK. Обратите 
внимание, что высоты 

устанавливаются относительно слоя 2. 

Рис. 66 

5. Выделите созданную перемычку и скопируйте её, щёлкнув по значку Copy на панели 
инструментов. Затем щёлкните по значку Paste на панели инструментов, щёлкните два раза 
правой кнопкой мышки, чтобы развернуть перемычку на 180 градусов. 

6. Поместите курсор на правый конец входного проводника и щёлкните мышкой, чтобы закрепить. 
Двухмерное отображение должно выглядеть, как на рис. 67, а трёхмерное - на рис. 68. 

Рис. 67 Рис. 68
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Добавление диэлектрической вставки, чтобы поместить в неё микросхему и 
проволочные перемычки. 

При установке элемента STACKUP для ЕМ структуры были определены диэлектрические слои, 
которые располагаются по всему размеру структуры. В Analyst можно добавлять диэлектрические вставки, 
которые занимают только часть объёма структуры. Для примера, добавим диэлектрическую вставку, 
которая покрывает проволочные перемычки и участок микросхемы с диэлектрическим материалом. 

Чтобы добавить диэлектрическую вставку: 
1. При активном окне 2-х мерного отображения ЕМ структуры PCB откройте менеджер топологии в 

левом окне и щёлкните по строке Drawing Layers. 
2. В левом окне Drawing Layers отметьте слой BCB. Щёлкните по значку Rectangle на панели 

инструментов. Переместите курсор к ЕМ структуре и нажмите клавишу Tab. В открывшемся окне 
координатного ввода введите в поле x 1650, в поле y введите 2100 (рис. 69) и нажмите OK. Снова 
нажмите клавишу Tab. В поле dx введите 1700, в поле dy введите 800 (рис. 70) и нажмите OK. 
Двухмерное представление ЕМ структуры будет, как на рис. 71, а трёхмерное - как на рис. 72. 

Рис. 69 Рис. 70 
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3. Чтобы посмотреть, где 
определён материал BCB, в 
левом окне просмотра 
проекта дважды щёлкните 
мышкой по Enclosure под 
именем ЕМ структуры PCB. 
Откроется окно свойств 
корпуса. На вкладке 
Material Defs определён 
диэлектрический слой BCB. 
На вкладке Materials 
определён материал BCB 
толщиной 250 um, которому 
назначен диэлектрический 
слой BCB. Нажмите OK. 

Рис. 71 

Рис. 72 

Моделирование всей структуры. 
Чтобы просматривать Е-поля для структуры после выполнения анализа, нужно установить 

определённые опции: 
1. Щёлкните правой кнопкой мышки по имени ЕМ структуры PCB в левом окне проекта и выберите 

Options. В открывшемся окне опций откройте вкладку Analyst. 
2. Для опции Field Output Frequency введите значение 

AMR Frequencies Only и нажмите OK. 
3. Откройте 3-х мерное отображение ЕМ структуры и 

щёлкните по кнопке Show Currents/Fields  на панели 
инструментов. чтобы отобразить поля на плоскости 
вырезки. После каждого обновления AMR будут 
обновляться и Е-поля. Здесь можно так же просматривать 
и обновление встраиваемой сетки, для этого щёлкните по 
значку Show 3D Mesh на панели инструментов. 
Убедитесь, что можно использовать плоскость вырезки, 
щёлкая по значкам Show Cut Plane и Use Cut Plane. 

4. Выберите в меню Simulate>Analyze или щёлкните по 
значку Analyze на панели инструментов. Сетка и Е-поле 
отображаются, как показано на рис. 73. После выполнения 

анализа можно щёлкнуть по кнопке Animate Play и наблюдать анимацию поля. 

Рис. 73 

Создайте график:  



1. Щёлкните правой кнопкой мышки по Graphs в левом окне просмотра проекта и выберите New 
Graph или щёлкните по значку Add New Graph на панели инструментов. 

2. Введите имя графика PCB, выберите тип графика Smith Chart и нажмите Create. 
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3. Щёлкните правой кнопкой мышки по новому графику и выберите Add New Measurement, чтобы 
добавить к графику измеряемую величину S11 (рис. 74). 

Рис. 75
Рис. 74

4. Щёлкните по кнопке Analyze на панели инструментов. Полученный график показан на рис. 75. 
Можно просмотреть Е-поле и встроенную сетку в трёхмерном отображении ЕМ структуры. При 

активном окне трёхмерной ЕМ структуры нажмите клавишу y, чтобы поместить плоскость вырезки в 
плоскость y и щёлкните по значкам Left и Show 3D Mesh на панели инструментов. Е-поле и встроенная 
сетка будут выглядеть, как показано на рис. 76. Щёлкните по значку Animate Play на панели инструментов, 
чтобы видеть анимацию Е-поля. 

Можно просматривать Е-поле и встраивание сетки для каждой последовательности AMR. Чтобы 
сделать это: 

1. При активном окне трёхмерного отображения ЕМ структуры раскройте группу Data Sets в левом 
окне проекта и затем раскройте подгруппу PCB (рис. 77). 

Рис. 77

2. Нажмите клавишу Shift и щёлкните мышкой по строке с данными в подгруппе EM_Sim DS1. 
Заметим, что Е-поле не отображается при выполнении AMR для порта (port-only). Эти записи в 
списке данных на рис. 77 отображаются с маленькой буквой P. 

Рис. 76 



Анализ только проволочных перемычек. 
При желании можно выполнить анализ не всей ЕМ структуры, а только её части. Например можно 

выполнить анализ только для проволочных перемычек. Это можно сделать перемещая границы 
поверхностей раздела и конфигурируя порты. 

В Analyst анализируются только формы топологии, которые находятся внутри поверхностей 
раздела. Поэтому не обязательно редактировать всю ЕМ структуру. 
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Сначала скопируйте всю уже созданную ЕМ структуру. Для 
этого: 

1. Щёлкните правой кнопкой по ЕМ структуре PCB в левом 
окне проекта и выберите Duplicate EM Structure. Будет 
создана новая ЕМ структура с именем PCB_1. 

2. Щёлкните правой кнопкой мышки по имени новой 
структуры PCB_1 и выберите Rename EM Structure. В 

открывшемся окне переименуйте созданную ЕМ структуру в PCB_Simplified (упрощенная) и 
нажмите Rename. 

Рис. 78

3. Аналогично создайте копию ЕМ структуры Analyst_Line и переименуйте её в 
Analyst_Line_Simplified. 

5. Откройте двухмерное отображение ЕМ структуры PCB_Simplified, щёлкните левой кнопкой по 
микросхеме, затем правой и выберите Element 
Properties. На вкладке Parameters измените 
параметр NET на Analyst_Line_Simplified, как 
показано на рис. 78. Нажмите OK. 

Порт 1 был изменён в ЕМ структуре  PCB на 
сосредоточенный. Теперь его нужно изменить обратно на 
волноводный, чтобы можно было установить референсную 
плоскость. Чтобы изменить расстояние от порта до 

референсной плоскости, щёлкните мышкой по порту 1, установите курсор мышки на правый край порта так, 
чтобы курсор отображался в виде двойной стрелки, нажмите левую кнопку мышки и переместите курсор 
вправо до левого края микросхемы (рис.79). 

Рис. 79 

Ко второму концу 
проволочной перемычки нельзя 
подключить порт таким же образом. 
Чтобы подключить порт к правому 
концу проволочной перемычки, 
нужно сдвинуть сюда правую 
сторону поверхностей раздела. Но 
сначала нужно сделать небольшое 

редактирование подсхемы Analyst_Line_Simplified: 

Рис. 81
Рис. 80 

1. Сделайте активным окно 
двухмерного отображения ЕМ 
структуры Analyst_Line_Simplified. 
Откройте менеджер топологии в 
левом окне проекта. Щёлкните по 
строке Drawing Layers и в этом окне 
отметьте слой Thick Metal. 

2. Выберете в меню Draw>Rectangle 
или щёлкните по значку Rectangle на 
панели инструментов. Переместите 
курсор в окно ЕМ структуры и 
нажмите клавишу Tab. Введите 
значения x и y, как показано на рис. 
80. снова нажмите клавишу Tab и 
введите значения dx и dy, как 

показано на рис. 81. 
Рис. 82 

3. Созданный прямоугольник 
будет выделен. Выберите в 
меню Draw>Add Edge Port 
или щёлкните по значку 
Edge Port на панели 
инструментов. ЕМ 
структура будет выглядеть, 
как показано на рис. 82. 

Рис. 83 Рис. 84 

4. Дважды щёлкните по имени ЕМ структуры PCB_Simplified в левом окне просмотра проекта, 
чтобы открыть двухмерное отображение этой ЕМ структуры. Щёлкните по значку View Area на 



панели инструментов, увеличьте отображение подсхемы, чтобы было удобнее её просматривать. 
Щёлкните по подсхеме мышкой, чтобы выделить её. Структура будет выглядеть, как показано на 
рис. 83. Т.е. порт 3 вместе с подсхемой не передан в общую ЕМ структуру, но место его 
подключения передано. 

5. Щёлкните по значку Edge Port на панели инструментов и добавьте порт, как показано на рис. 84. 
6. Выберите в меню View>View All, чтобы отобразить всю ЕМ структуру (рис. 85). 
7. Щёлкните по порту 2, чтобы выделить этот порт, и нажмите клавишу Delete, чтобы удалить этот 

порт. Теперь нужно упорядочить нумерацию портов. Для этого выберите в меню Edit>Re-number 
Ports.  
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Теперь нужно переместить правую сторону граничной формы ко вновь созданному порту. Чтобы 
сделать это: 

Рис. 86 Рис..85 

1. Дважды щёлкните по какой-нибудь стороне граничной формы. В центрах сторон и по углам 
появятся небольшие ромбики и квадратики, как показано на рис.86. 

2. Установите курсор на ромбик на правой стороне граничной формы так, чтобы курсор отображался 
в виде двойной стрелки, нажмите левую кнопку мышки и перемещайте курсор влево до тех пор, 
пока сторона граничной поверхности совпадёт с плоскостью расположения порта 2. 

Рис. 87 Рис. 88 



3. Увеличьте отображение ЕМ структуры 
в районе порта 2, чтобы убедиться, что 
поверхность раздела совпадает с 
плоскостью расположения порта. Если 
это не так, поправьте положение 
стороны поверхности раздела. 

4. Полное двухмерное отображение ЕМ 
структуры должно быть, как показано 
на рис. 87, а 3-х мерное - как на рис. 88. 

Теперь ЕМ структура готова к 
выполнению анализа. 

Щёлкните по значку Analyze на панели 
инструментов. В процессе выполнения анализа 
можно наблюдать, как изменяется сетка, 
встроенная в ЕМ структуру, на каждом шаге 
обновления AMR. При этом изменяется только 
сетка, встроенная в граничную форму. 

Пока выполняется анализ, щёлкните 
правой кнопкой мышки по графику PCB и 
выберите Add Measurement. Добавьте к графику 
измеряемую величину S11 для ЕМ структуры 
PCB Simplified. 

График будет выглядеть, как показано на 
рис. 89. 

Рис. 89 

Пример использование произвольных 3D-структур в Analyst. 
Существует множество способов использования трехмерных структур в симуляторе Analyst. Можно 

использовать компоненты с параметрами, заданными производителем, предоставляемые им в сети Интернет 
в виде XML файлов. Кроме того, можно создавать собственные статические или параметризованные 
трехмерные компоненты в 3D-редакторе AWRDE. Благодаря множеству параметров, доступных для 
создания/использования, упрощается настройка трехмерной структуры. 

Создание и импорт 3D структур. 
В этом примере будет выполнено присоединение разъёма типа SMA, а также поместим выводы и 

ранее созданные элементы в диэлектрический корпус. Разъем SMA является предустановленной 
структурой, разработанной в 3D-редакторе AWR Design Environment. 

Данный пример состоит из следующих этапов. 
 Соединение платы и разъёма SMA. 
 Заключените выводов в диэлектрический корпус. 
 Анализ полной структуры. 
 Отображение результатов. 

Чтобы сократить время моделирования для этого примера, загрузите наборы данных симуляции с 
сайта https://awrcorp.com/support/help.aspx?id=46. 

Примечание. Документ Quick Reference содержит перечень горячих клавиш, операций мышью, 
советов и приемов по оптимизации работы с программой. Чтобы перейти к этому документу, выберите 
Help>Quick Reference. 

Открытие существующего проекта 
Пример из этой главы доступен полностью как Analyst_Arbitrary_Finish.emp. Чтобы открыть этот 

файл из списка примеров проектов, выберите File>Open Example, в открывшемся диалоговом окне Open 
Example Project удерживайте нажатой клавишу Ctrl и щелкните заголовок столбца Keywords, затем 
введите getting_started в текстовом поле в нижней части диалогового окна.  

Чтобы открыть проект: 
1. Выберите File>Open Example, чтобы найти и открыть файл Analyst_Hierarchy_Finish.emp. 
2. Выберите File>Save Project As. Откроется диалоговое окно Save As. 
3. Перейдите в рабочую папку, где требуется сохранить проект, введите название проекта 

Analyst_GS_arbitrary и нажмите Save. 

Добавление разъема SMA. 
Добавим разъёмы SMA к ранее созданной ЕМ структуре PCB. Так как используется ещё один 

уровень иерархии, можно проводить анализ самих чипа и подложки, а затем той же структуры, но уже с 
разъёмами, чтобы оценить влияние последних на характеристики схемы. 

 24



Чтобы добавить разъемы SMA: 
1. Щелкните правой кнопкой мыши по EM 

Structures в левом окне просмотра проекта 
и выберите New EM Structure. Либо 
выберите в меню Project>Add EM 
Structure>New EM Structure, или нажмите 
кнопку Add New EM Structure на панели 
инструментов для отображения диалогового 
окна New EM Structure. 
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2. Введите имя структуры SMA, выберите 
AWR Analyst 3D EM - Async в качестве 
симулятора, выберите From Stackup для 
Initialization Options, AIR для Stackup 
(рис. 90). Нажмите Create. 

3. При активном окне двухмерного вида 
дважды щелкните мышкой по граничной 
области для перехода в режим 

редактирования. По краям области появятся ромбы и квадраты. 

Рис. 90 

4. Нажмите и перетащите правый верхний угол квадрата и нажмите Tab. В диалоговом окне Enter 
Coordinates снимите флажок Rel и введите значения, соответствующие граничной области 
размером 750x500 мил. 

5. Щелкните правой кнопкой мышки в окне двухмерного вида и выберите View All для отображения 
всей граничной области. 

6. Выделите граничную область, щелкните правой кнопкой мыши и выберите Shape Properties, 
чтобы открыть диалоговое окно Properties. Перейдите на вкладку Boundary Conditions и 
убедитесь, что настройки совпадают с настройками, представленными на рисунке 91. 

7. Теперь добавим схему PCB к документу SMA. Активировав окно топологии ЕМ-структуры SMA, 
выберите Draw>Add Subcircuit, чтобы открыть диалоговое окно Add Subcircuit Element (рис. 
92). Выберите PCB и нажмите OK. 

Рис. 92 Рис. 91 

8. Поместите подсхему внутри граничной области. Чтобы привязать подсхему к этой области, 
нажмите клавишу Ctrl и щёлкните мышкой (рис. 93). 

9. Выберите подсхему PCB, щелкните правой кнопкой мышки и выберите Shape Properties, чтобы 
открыть диалоговое окно Cell Options. В разделе Z Position измените EM layer на 3 (рис. 94). 
трёхмерный вид структуры SMA будет выглядеть как показано на рис. 95. 

Рис. 95Рис. 93 Рис. 94



10. При активном окне 
двухмерного вида ЕМ 
структуры SMA в левом окне 
просмотра элементов в разделе 
3D EM Elements разверните 
категорию Libraries и 
щелкните по подгруппе 
Connectors>SMA. Выберите 

модель SMACONFIG и поместите её над структурой SMA. 

Рис. 96
Рис. 97

11. Перетаскивая SMACONFIG в ЕМ структуру SMA нажмите клавишу Tab, в открывшемся 
диалоговом окне Enter Coordinates в поле x введите 0, в поле y введите 250 mil (рис. 96). 
Нажмите OK. Будет создана фигура, показанная на рис. 97. 

12. Выберите подсхему PCB, щелкните правой кнопкой мыши и выберите Element Properties, чтобы 
открыть диалоговое окно Element Options: SUBCKT Properties. Убедитесь, что настройки для 
ContactType, GndTabUpV off и GndTabLowV off совпадают с показанными на рис. 98 и нажмите 
OK. Все остальные значения оставьте по умолчанию. 

13. Щелкните правой кнопкой мышки по SMACONFIG еще раз и выберите Shape Properties, чтобы 
отобразить диалоговое окно Cell Options. В разделе Z Position измените EM layer на 2 (рис. 99). 

14. Скопируйте элемент SMACONFIG и вставьте его на противоположной стороне структуры. После 
поворота структуры нажмите клавишу Tab, снимите флажок Rel и введите 802 для X и 250 для Y. 

Рис.99Рис.98

15. Выберите Draw>Add Edge Port и установите курсор мыши на край центра проводника слева SMA 
до отображения контура порта. Щелкните мышкой для размещения порта. Повторите этот шаг для 
правого порта. После этого двухмерный вид должен отображаться как показано на рис. 100, 
трёхмерный вид на рис. 101. 
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16. Чтобы убедиться, что все соединения выполнены 
корректно, в окне трёхмерного  вида ЕМ структуры SMA 
нажмите кнопку Show Mesh Connectivity на панели 
инструментов. На рис. 18.102 показано окно трёхмерного 
вида после включения просмотра сетки Mesh 
Connectivity. 

Рис. 101Рис. 100

Примечание. Граничные условия распространяются на 
все структуры в иерархии, поэтому плоскость заземления ЕМ 
структуры PCB представлена в ЕМ структуре SMA. 

Рис. 102 



Добавление контактных площадок. 
Прежде, чем перейти к моделированию, создадим более реалистичную структуру, включающую 

контактные площадки для крепления разъёма SMA. На том же уровне иерархии, что и сами разъёмы, можно 
создать четыре медные площадки с перемычками. Конечный проект включает эти контактные площадки. 

Чтобы создать контактные площадки и перемычки: 
1. Откройте двухмерный вид 

ЕМ структуры SMA и в 
левом окне просмотра 
откройте менеджер 
топологии Layout. 

2. Выберите слой Copper в 
окне менеджера топологии, 

затем щёлкните по значку Rectangle на панели инструментов или выберите в меню Draw 
Rectangle, переместите курсор в окно ЕМ структуры и нажмите клавишу Tab. В открывшемся 
диалоговом окне Enter Coordinates введите значения, показанные на рис. 103 и нажмите OK. 

Рис. 104Рис. 103 

3. Нажмите клавишу Tab снова и 
введите координаты, показанные на 
рис.104 при отмеченном Rel. 

4. В окне менеджера топологии в EM 
Layers отметьте слой черчения Via, 
выберите в меню Draw>Circle и 
нажмите клавишу Tab, чтобы 
открыть окно Enter Coordinates. 
Введите 30 в поле x, введите 82 в 

поле y и нажмите OK. 

Рис. 105 

5. Нажмите клавишу Tab еще раз и введите 15 в поле dx. Убедитесь, что флажок Rel установлен. 
6. Скопируйте перемычку и вставьте её справа два раза с интервалом в 60 мил. При вставке можно 

нажать Tab, чтобы ввести координаты для равномерного размещения перемычек. В итоге должно 
получиться как показано на рис. 105. 

Рис. 106 
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7. Скопируйте площадку и перемычки и вставьте их в нужных местах и в нужных положениях под 
гребнями разъёма SMA. Результат должен выглядеть примерно как показано на рис. 106. 
трёхмерное отображение полученной структуры на рис. 107. 

Рис. 107 

Моделирование структуры целиком. 
Для просмотра электрических полей в структуре после моделирования, необходимы следующие 

настройки: 
1. Щелкните правой кнопкой мышки по ЕМ структуре SMA и выберите Options, чтобы открыть 

диалоговое окно Options, затем перейдите на вкладку Analyst. 
2. Измените Field Output Frequency на AMR Frequencies Only и нажмите OK. 
3. Нажмите кнопку Show Currents/Fields на панели инструментов трёхмерного отображения ЕМ для 

отображения поля. Картина поля обновляется после каждой итерации AMR. 
4. В активном окне трёхмерного отображения ЕМ структуры SMA нажмите кнопку Show 3D Mesh 

на панели инструментов для отображения сетки структуры и наблюдайте за обновлением сетки 
для каждого шага AMR. 

5. Выберите в меню Simulate>Analyze или нажмите кнопку Analyze на панели инструментов чтобы 
выполнить анализ. 

Заметим, что анализ выполняется в том же диапазоне, что и в предыдущем примере от 1 до 10 ГГц с 
шагом 1 ГГц. 

Чтобы создать график: 
1. Щелкните правой кнопкой мышки по значку Add New Graph на панели инструментов или 

выберите в меню Project>Add Graph. 
2. Введите имя графика SMA, выберите тип графика Smith Chart и нажмите Create. 
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3. Щелкните правой кнопкой мышки по имени графика в левом окне просмотра проекта  и выберите 
Add New Measurement, чтобы добавить измеряемую величину S11 для графика. Убедитесь, что 
установки в открывшемся окне совпадают с показанными на рис. 108. 

Рис. 109 Рис. 108 

4. Полученный график показан на рис. 109. 

На трёхмерном отображении можно увидеть результат моделирования электрических полей. В окне 
трёхмерного отображения нажмите клавишу y , чтобы развернуть секущую 
плоскость. Поле будет отображаться примерно как показано на рис. 110. 

Рис.110 Рис. 111 

Чтобы увидеть поля в структуре за металлом, нажмите и удерживайте 
секущую плоскость. Будут отображены поля, скрытые за металлом (рис. 111). 

Также можно отобразить сетку и поля для каждой итерации AMR во 
время или по завершении анализа. Для этого: 

1. При активном окне трёхмерного отображения ЕМ структуры SMA 
разверните группу Data Sets в левом окне просмотра проекта, а затем 
разверните подгруппу SMA щёлкнув мышкой по значку + слева от 
имени группы. Будет показан весь имеющийся набор данных для всех 
выполненных анализов (рис. 112). 

2. Нажмите клавишу Shift и щелкните мышкой интересующий подпункт 
набора данных для отображения сетки и электрических полей данного 
подпункта. Обратите внимание, что электрическое поле не 

отображается для выполненных анализов, связанных только с портами. Отображается прописная 
буква «P» на значке набора данных (занимают последнее место в списке). 

Рис. 112 

Настройка для анализа только части структуры. 
Иногда может пригодиться выполнить моделирование только части созданной структуры. В данном 

примере рассмотрим выполнение моделирования только разъёма SMA чтобы оценить его влияние при 
добавлении разъёма в цепь. 

Это можно сделать, сдвинув граничную область и перенастроив порты. При этом вносить 
изменения в созданную геометрию не нужно. 

В Analyst моделируются только те фигуры, которые целиком попадают в граничную область, 
поэтому можно проводить анализ частей геометрии без необходимости перерисовывания отдельных её 
частей. На следующем этапе будет проведено моделирование разъёма SMA, установленного в рамках 
предыдущего примера. 

Сначала создадим копию уже созданной структуры. Для этого: 



1. Щелкните правой кнопкой мышки по ЕМ структуре SMA и выберите Duplicate. В группе 
проектов появится новая ЕМ структура с именем SMA_1. 

2. Щелкните правой кнопкой мышки по имени SMA 1 и выберите Rename EM Structure. В 
диалоговом окне Rename EM Structure введите новое имя SMA_Simplified, затем нажмите 

3. В окне SM
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п

графику 
учиться примерно как 

на рис. 1

Rename. 

A_Simplified дважды щелкните мышкой по граничной области, чтобы перейти в режим 

та, как это показано на рис. 113. 

едитесь, 

 и введите 

а дважды 

 

S11 к 

показано 

Рис. 18.114

Рис. 116

Рис. 115Рис. 113

редактирования (на гранях и в углах появятся ромбы и квадраты). 
4. Нажмите и перетащите ромб на правой грани области в 

сторону пор
5. Приблизившись к порту 1, нажмите клавишу Tab и 

введите значения, показанные на рис. 114. Уб
что установлен флажок Rel. 

6. Укажите слой Copper для фигуры и выберите 
Draw>Rectangle. Нажмите клавишу Tab

мание на флажок Rel. 

на предыдущем шаге. После добавления порт

координаты, показанные на рис.115. Нажмите OK. 
7. Нажмите клавишу Tab еще раз и введите значения, показанные на рис. 116. Нажмите OK. 

Обратите вни

Рис. 117 

8. Удалите порт 2 с правой стороны. Выберите Draw>Add Edge Port для добавления порта в правый 
край прямоугольника, созданного 
щелкните по нему мышкой и измените Type с Lumped Down на Wave как показано на рис. 117. 

9. Несмотря на то, что правый разъём SMA не попадает в граничную область, при текущих 
настройках он будет включен в анализ. Чтобы этого избежать, щелкните левой кнопкой мышки по

Рис. 119 

Рис. 118 

правому разъему SMA, затем правой кнопкой мышки и 
выберите Shape Properties. В открывшемся диалоговом 
окне Cell Options на вкладке Layout отметьте Clipped by 
simulation boundary (рис. 118). Структура будет выглядеть 
как показано на рис. 119. 

Запустите анализ. Анализ обычно занимает несколько минут 
ри свободных ресурсах компьютера. 

Пока идёт анализ, добавьте измеряемую величину  
SMA, чтобы получить отклик цепи по завершении 

моделирования. Результат должен пол
20. 

Рис. 120 
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