Помощь - Поиск - Пользователи - Календарь
Полная версия этой страницы: Привод двигателя постоянного тока на TDA1085
Форум разработчиков электроники ELECTRONIX.ru > Силовая Электроника - Power Electronics > Электрические машины, Электропривод и Управление
pritula
Добрый день !
Собрал плату по схеме Богдана, не запускается двигатель, есть подозрение, что дохлые TDA1085, пробовал менять, также промерял напряжения без TDA, режимы соответствуют, ошибок в плате нет.
http://www.chipmaker.ru/index.php?autocom=...p;showfile=1490
http://www.chipmaker.ru/topic/36911/page__...da1085__st__420

не нашёл режимы напряжений на ножках TDA, промерял у себя, вызывает подозрения:
- pin7 - должно расти U при включении, но у меня 50 mV, получается согласно даташита ограничение тока по pin3,
- pin3 - закорочен на pin8, для настройки, ограничение тока не работает
- pin5 - установлено U=6 V
- pin6 - установлено U=6 V
- pin9 - U=14,9 V
- pin4 - у меня 30 mV, но должно расти, сколько ?
- pin16 - у меня 20 mV, но должно быть выше, сколько ?

ПРОСЬБА.
если возможно, проверьте на работающем девайсе pin7, ну и если можно остальные режимы на ножках.

Спасибо за внимание.
Сергей.



pritula
Удивительно, но TDA поднялась только на 15,4 V, хотя в даташите указано Vmin - 15 V, работает
Александр1
Когда-то было много стиралок в ремонте с приводом на TDA1085. Но одна так достала, что даже срисовал схему с натуры. Срисованная схема отличается от datasheet TDA1085: в ней еще применена одна ИМС, скорее всего, LM393 (тип не записал).
Уже не помню точно, что за проблема была. Некоторые моменты законспектировал.
В моей схеме на выв 16 - напряжение питания при макс переменном напряжении на выходе (т.е. симистор открывается в самом начале полупериода). Это когда двигатель запущен и все работает. Возможно на выв 16 может быть и не напряжение питания, но у меня так записано, подробностей уже не помню. НО! Потом, при обрыве датчика скорости на выв 16- 2В. При изначально оборванном датчике скорости - 0В.
На выв 7 при изначально оборванном датчике скорости появляется 0 В. При обрыве датчика в процессе работы - тоже устанавливается 0. Это то, что я законспектировал.
На выв 12 в моей схеме с плюса питания подключен резистор 470 кОм. Режим не измерял.
Еще помню, что при исправном датчике скорости, но механически не связанном с двигателем, схема кратковременно попытается запустить двигатель. Это выглядело как кратковременный рывок двигателя и затем схема стоит и ждет чего-то biggrin.gif . После выкл и вкл питания все повторяется.
Возможно, эта информация чем-то будет полезна.

Цитата(pritula @ Jul 22 2015, 12:52) *
Удивительно, но TDA поднялась только на 15,4 V, хотя в даташите указано Vmin - 15 V, работает

Я видел в datasheet максимальное напряжение на выв 9 - 15В.
pritula
Спасибо, Александр, достаточно полезная инфа

TDA поднялась только на 15,4 V питания на Pin9, хотя в даташите указано Vcc(min) - 15 V, Vcc(typ)=15,3 V, Vcc(max)=16 V
Tanya
Цитата(pritula @ Jul 22 2015, 13:05) *
Спасибо, Александр, достаточно полезная инфа

TDA поднялась только на 15,4 V питания на Pin9, хотя в даташите указано Vcc(min) - 15 V, Vcc(typ)=15,3 V, Vcc(max)=16 V

А Вы уверены в Вашем вольтметре? А пульсации там есть?
Plain
Цитата(pritula @ Jul 22 2015, 13:05) *
TDA поднялась только на 15,4 V питания на Pin9, хотя в даташите указано

Проясните, что Вы делаете, потому что у микросхемы шунтовый стабилизатор, т.е. питаемый током, а подача в обход него какого-либо напряжения её гарантированно выжгет.
pritula
В тестере на напряжении уверен, проверяем его В7-16ым
про параллельный (шунтовый) стабилизатор согласен, можно выжечь.

TDA уже работает, регулирует, возникли другие проблемы:

1. при первом включении от сети / или от резистора на Pin5 (при U менее 0,08 V - стоп)
пусковой ток очень большой (рывок), при этом чем больше установлена скорость, тем больше пусковой ток.

2. резистор с Pin13 на управляющий симистора установлен резистор 330R, симистор BTA20BW Igt (1)min=2 mA, Igt (1)max=50 mA,
c TDA идут пачки импульсов гарантированного открытия U~14 V, переход BTA 1,5 V, остаток 12,5 V, I=12,5/0.330=38 mA (не превышен)
уже на 2-х симисторах пробило переход с управляющего G на А1 при работе на повышенных токах (в импульсе 10 А)


В тестере на напряжении уверен, проверяем его В7-16ым, пульсаций нет
про параллельный (шунтовый) стабилизатор согласен, можно выжечь.

TDA уже работает, регулирует, возникли другие проблемы:

1. при первом включении от сети / или от резистора на Pin5 (при U менее 0,08 V - стоп)
пусковой ток очень большой (рывок), при этом чем больше установлена скорость, тем больше пусковой ток.

2. резистор с Pin13 на управляющий симистора установлен резистор 330R, симистор BTA20BW Igt (1)min=2 mA, Igt (1)max=50 mA,
c TDA идут пачки импульсов гарантированного открытия U~14 V, переход BTA 1,5 V, остаток 12,5 V, I=12,5/0.330=38 mA (не превышен)
уже на 2-х симисторах пробило переход с управляющего G на А1 при работе на повышенных токах (в импульсе 10 А)

Plain
Сравните требуемую производителем разводку на Рис.5 паспорта с Вашей.

Но даже сам производитель здесь нарушает собственные же требования по включению производимого им же симистора, подвесив его на сильноточной индуктивности и лишив шунтирующего резистора.

Так что, существующая редакция схемы и платы способна выдавать лишь подобные сюрпризы.
pritula
да, согласен, сейчас пытаюсь исследовать сюрпризы, привлекает то, что возможна достаточно простая аппаратная реализация

ведь вроде как много стиральных машинок ранее работали на TDA1085 достаточно надёжно, указан симистор МАС15 (запираемый), а также другие изменения,
надо разбираться

журнал "Ремонт и сервис" взял с http://www.chipmaker.ru/topic/36911/page__...da1085__st__420
pritula
Решение проблем:

1. оказалась при включении, при переходных процессах видны высокие уровни на генераторе импульсов запуска, его вход - Pin16
установленная интегрирующая цепочка 47 мкф и 68 ком на Pin16 была быстровата, установлен резистор вместо 68 к - 15 к,
при запуске РЫВКА НЕТ
P.S. в стиральных машинках для устранения рывка при переходных процессах устанавливали УПТ с конденсатором на входе и снимали потенциал на Pin7, возникающий при переходных процессах TDA

2. заменил TDA и симистор из других партий - проблема исчезла, но резистор с Pin3 на управление симистора - 150 Ом, поскольку при 500 Ом симистор открывается только на положительной полуволне напряжения сети, а защита работает на отрицательной полуволне, да и мощность мала при одной полуволне

Получился СИФУ с обратной связью по тахогенератору (8 имп/оборот, но лучше 16 имп/об, это по даташиту)
Мощность на валу (крутящий момент) поддерживает достаточно неплохо

приступаем к реализации самого проекта привода станка на аппаратной реализации
( требование - ремонт должен быть возможен без прошивок контроллеров)
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.
Invision Power Board © 2001-2018 Invision Power Services, Inc.