Помощь - Поиск - Пользователи - Календарь
Полная версия этой страницы: Ошибки работы Altium Designer 15
Форум разработчиков электроники ELECTRONIX.ru > Печатные платы (PCB) > Разрабатываем ПП в САПР - PCB development > Altium Designer, DXP, Protel
Страницы: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17
Alexey Sabunin
Друзья,

Чтобы немного упорядочить обработку ошибок, решил выделить ошибки новой версии в отдельную ветку. Прошу здесь сообщать только об ошибках, обнаруженных в этой версии. Старая тема пока также актуальна, т.к. часто важно знать, момент когда ошибка появилась - это сильно упрощает ее обработку и исправление.

Хотелось бы отметить, в отличии от предыдущих лет, после выпуска 15-й версии будет вестись и поддержка 14-й! Планируется в течении некоторого времени выпускать обновления для 14-й версии, если там будут обнаружены ошибки, мешающие работать, и при этом появившиеся именно в 14 выпуске!

Если вы не занете в какую тему сообщить об ошибке, пишите в любую - модераторы потом переместят сообщение в более подходящую тему.

Спасибо!
Uree
После включения видимости соединений в РСВ сразу их отображения не происходит. Часть отображается, а часть начинает быть видимой только после того, как сдвинутся компоненты к которым эти соединения идут. Так было в 14.3.14, теперь так же себя ведет 15.0.7
Известный глюк или никто не замечал?
Владимир
Замечал, не всегда, не везде но бывает
ClayMan
Цитата(Владимир @ Nov 24 2014, 12:07) *
Замечал, не всегда, не везде но бывает

В этой фразе - суть всего пакета)

По сабжу - тоже замечал такое. Есть ощущение, будто это зависит от кол-ва связей на плате.
Uree
Кстати выключение отображения соединений работает стабильно правильно.

Еще глюк отображения вспомнился:
- выключаем отображение соединений
- перемещаем группу компонентов
- включаем соединения
ОППА! А они показаны идущими в СТАРОЕ место расположения компонентов!

Имеется такое:

Нажмите для просмотра прикрепленного файла

после выполнения описанного получаем следующее

Нажмите для просмотра прикрепленного файла

Ну красота... Кто придумал использовать игровое АПИ для задач к этому не подходящих?..
Владимир
так обновить надо
Uree
Что обновить? Изображение?
Владимир
Нет, толи импортировать из схемы,толи перекомпилить.
в 15 версии, я пока не смог это смоделировать. Но в старых версиях-- да, бывало
peshkoff
Цитата(Uree @ Nov 24 2014, 12:20) *
Кстати выключение отображения соединений работает стабильно правильно.

Еще глюк отображения вспомнился:
- выключаем отображение соединений
- перемещаем группу компонентов
- включаем соединения
ОППА! А они показаны идущими в СТАРОЕ место расположения компонентов!


End нажать. это redraw будет.

вы еще и в антиалиазинге работаете? И как он все это дело ворочает? У меня и без этих красот все тормозит со страшной силой....
Uree
Хороший вопрос, в чем я работаю... Насколько я понял из настроек, сглаживание работает для 3D, для 2D настройки не нашел. Где искать?
Ну и пока на экране 2-3 слоя + шелк тормозов не заметно. Вот на 8-ми включенных, да если еще и с фильтрацией - вот тут все дохнет конечно. Точнее живет, но при смертиsm.gif Причем это явно проблема софта, ибо железо тянет, ни проц, ни видео на 100% не загружаются.

Обновление не работает. Кроме того - можно делать какие угодно действия с другими элементами, перемещать их, зумить, сохранять-закрывать-открывать файл - отображение цепей висит на том же месте. Пока именно не передвинешь компоненты, к которым относятся соединения. Только тогда происходит реальное обновление.
Что еще заметил - такой эффект получается при следующей последовательности действий:
- отключаем видимость цепей
- перемещаем кусок дизайна достаточно большой, чтобы не отображалось его содержимое(только прямоугольник контура)
- включаем видимость... вуаля!

И вот тут начинаются интересности. Некоторые цепи так и не начинают отображаться, некоторые тянутся в старые координаты падов, где тех уже нет... в общем интересно становится. Столько лет продукту, 3D хваленое, а банальное управление отображением объектов в базовом 2D не работает, причем, имхо, одних из самых важных объектов. Вот как после этого можно серьезно говорить о таком продукте, как о рабочем инструменте?..
Alexey Sabunin
Цитата(Uree @ Nov 24 2014, 12:20) *
Еще глюк отображения вспомнился:
- выключаем отображение соединений
- перемещаем группу компонентов
- включаем соединения
ОППА! А они показаны идущими в СТАРОЕ место расположения компонентов!

Если кто-то может это повторить - перешлите мне пожалуйста плату, где это стабильно воспроизводится! Я у себя не могу такое получить даже на больших платах.
Если такое поведение наблюдается, это конечно не правильно - будем исправлять, если сможем повторить!
Владимир
попадалось, примерно раз-два в год и в чужих проектах.
peshkoff
Uree, а какой операцией вы включаете-выключаете соединения? и какая версия ad?
Uree
Господа, я конечно новичок в АД, но вообще вроде бы не первый день за компом.
Версия 15.0.7, видимостью через список цепей управляю(можно и по-компонентно, но у меня нет столько времени на игрушки).
Итак, всем известный файл из папки с примерами к АД.

Вытягиваю за плату несколько компонентов(этого кол-ва уже достаточно, чтобы их не было видно при перемещении)

Нажмите для просмотра прикрепленного файла

отключаю видимость соединений

Нажмите для просмотра прикрепленного файла

перемещаю эту же группу еще раз

Нажмите для просмотра прикрепленного файла

включаю видимость

Нажмите для просмотра прикрепленного файла

обновляю экран

Нажмите для просмотра прикрепленного файла

Каждый может повторить. Ничего не выдумано. Скриншоты сделаны 5 минут назад. Могу повторить с любой другой платой.

Возможно это что-то с настройками, но я ничего специально не конфигурил и откуда такое поведение мне непонятно.
peshkoff
Цитата(Uree @ Nov 25 2014, 12:01) *
Господа, я конечно новичок в АД, но вообще вроде бы не первый день за компом.
Версия 15.0.7, видимостью через список цепей управляю(можно и по-компонентно, но у меня нет столько времени на игрушки).
Итак, всем известный файл из папки с примерами к АД.


в 13 такая же песня.

при отключении таким способом, да, глюк повторяется

p.s. Uree, у меня тоже нет времени на игрушки и волнуют те же вопросы, что и вас.
отключать покомпоненто у меня тоже нет времени. я имел ввиду отключение глобально, чем я иногда пользуюсь во вкладке View Configuration.
в этом случае работает все правильно.
Владимир
Повторил, с тем же проектом и примерно теми же элементами

Ни каких проблем. Все связи перенеслись как надо.


Но повторяю, 1-2 раза в год с чужими проектами это бывало.
Uree
Через глобальное отключение не вариант. Я обычно классами оперирую, делая размещение. А классами только через список цепей можно.
О компонентах написал потому, что так тоже пробовал - процесс долгий и в общем не подходящий(разные классы на компоненте есть всегда), а результат отображения такой же.
И только у Владимира все в порядке... у Вас спец. версия какая-то?sm.gif Или где-то в глубине настроек какая-то птица в нужном месте (не)стоит?
Владимир
15.0.7
Смысл в том, что я давно перестал настраивать конфигурации, сильно отличающиеся от стандартных.
Может в этом суть дела
TMG
Версия 15.0.7
Сбрасывается значения поля Library Description в свойствах библиотеки.
Попутно вопрос - для чего вообще это описание нужно? Где его можно увидеть кроме как в этом окне?
Владимир
Цитата(TMG @ Nov 25 2014, 17:51) *
Версия 15.0.7
Сбрасывается значения поля Library Description в свойствах библиотеки.
Попутно вопрос - для чего вообще это описание нужно? Где его можно увидеть кроме как в этом окне?

Для этого и нужно, чтобы написать, что там есть, для памяти.
Можете не использовать
filmi
AD15.0.7
3D Snapshot не делается (не выскакивает окно с предложением выбрать разрешение) если не выделен ни один элемент на плате. Если выделить элемент то все ок. Но както оно через Ж.
Вроде в новой версии чтото поменялось в этой части, но 300 DPI на платах больше 5х5см так и не работает!
Alexey Sabunin
Цитата(Uree @ Nov 25 2014, 12:01) *
Господа, я конечно новичок в АД, но вообще вроде бы не первый день за компом.
Версия 15.0.7, видимостью через список цепей управляю(можно и по-компонентно, но у меня нет столько времени на игрушки).

Подтверждаю, ошибка есть! Я обычно выключаю клавишами N>H>A и включаю N>S>A. При описанном выше порядке действительно цепи не перерисовываются. Спасибо за описание - будем исправлять.

p.s. Именно эта ошибка появилась не в 15-й версии.
Alex Ko
Глюк появился в 14-м и остался (навеки? crying.gif ). Связан, скорее всего, с видеокартами ATI(серии 4800, если чё) ибо проявлялся на 2 компах, 3-х системах (ХР, 7-32, 7-64) с этими картами и исчез в одном из них с заменой на NVidia.
Когда открыто несколько программ, и до AD работаешь в окне другой программы, то при после "множественного (из всплывающего меню) выбора" система перекидывает фокус в окно той, другой программы. Можно вернуться (по Alt+Tab) и продолжить, но нервирует изрядно. Научился бороться, открыв 2 окна АД (благо, у меня 2 монитора), и перед работой в главном использовать другое, но это как-то.. неаккуратно. Или уж пишите в требованиях к железу - ATI/AMD - Низззя!!
Turnaev Sergey
Цитата(Uree @ Nov 25 2014, 12:01) *
Каждый может повторить. Ничего не выдумано. Скриншоты сделаны 5 минут назад. Могу повторить с любой другой платой.

У меня тоже повторяется. Версия 15.0.7.
Alex Ko
Новые Teardrops не всегда образуются корректно, иногда конфликтуют с близлежащими трассами. Старые (кривыми/прямыми трассами) работают правильно.
Alex Ko
Ещё.. Хотя тут я не уверен, может, настройки какие слетели.. Когда в режиме Single Layer, Мех-1 слой (у меня там очертания компонента и копия дизайнатора), то не могу выбрать компонент целиком.. То же в слое Оверлея.. Где-то галки не хватает или глюк?
Владимир
Так компонент приписан к слою Top, а не к механическому. А в назначении механических нет привязки к стороне.
Тоже про Overlay. Хотя тут было бы приятней наличие выбора.
peshkoff
Цитата(Alex Ko @ Nov 26 2014, 13:07) *
Ещё.. Хотя тут я не уверен, может, настройки какие слетели.. Когда в режиме Single Layer, Мех-1 слой (у меня там очертания компонента и копия дизайнатора), то не могу выбрать компонент целиком.. То же в слое Оверлея.. Где-то галки не хватает или глюк?


Такой вариант ввели по якобы "многочиленным просьбам" в 14 версии. Теперь компоненты можно выделить только если текущий слой Top иил Bottom.
Естественно, введено окончательно и бесповоротно, никаких тебе галочек, чтобы сделать как раньше.
Alex Ko
Цитата(Владимир @ Nov 26 2014, 14:04) *
Так компонент приписан к слою Top, а не к механическому. А в назначении механических нет привязки к стороне.
Тоже про Overlay. Хотя тут было бы приятней наличие выбора.
Да я не против, но раньше это работало! И было удобно..
filmi
Цитата(filmi @ Nov 25 2014, 18:31) *
AD15.0.7
3D Snapshot не делается (не выскакивает окно с предложением выбрать разрешение) если не выделен ни один элемент на плате. Если выделить элемент то все ок. Но както оно через Ж.
Вроде в новой версии чтото поменялось в этой части, но 300 DPI на платах больше 5х5см так и не работает!

Кто может подтвердить ошибку или это только у меня такой глюк?
peshkoff
Цитата(filmi @ Nov 26 2014, 17:19) *
Кто может подтвердить ошибку или это только у меня такой глюк?


Да так и есть. 300 dpi не работало еще с 13 или даже 12 версии, короче, давное уже.
А в 15 перестало работать вообще, пока не выберешь какой-нибудь компонент. в чем связь не понятно
Alexey Sabunin
Цитата(Alex Ko @ Nov 26 2014, 11:55) *
Новые Teardrops не всегда образуются корректно, иногда конфликтуют с близлежащими трассами. Старые (кривыми/прямыми трассами) работают правильно.

По всем вопросам прошу по возможности прикладывать рисунки и файл, где это можно проверить.
peshkoff
Цитата(Alexey Sabunin @ Nov 27 2014, 10:36) *
По всем вопросам прошу по возможности прикладывать рисунки и файл, где это можно проверить.


Прикладываю.
Так, небольшой тест на 10 минут. О полноценной работе само собой разговора то не может идти.

Решил выбрать самое одно из самых больных мест альтиума, уж извините.. Полигоны.

Значит, первое: убрали возможность постоянной перезаливки полигонов Repour-Always


Теперь нас каждый раз при прикосновении к полигону будут спрашивать:


Ну а что вы хотели? Вы думали, что вы все знаете?
Я бы предложил еще ввести кнопочку с замочком, которая требует прав администратора, а в будущем еще прикладывать документ от руководства о разрешении перезаливки.
Ну а что, мы же ТУПЫЫЫеее...

Ладно, начинаем рисовать.
Вот так выглядят процессы рисования в 13 (блин, а я, нелюдь, когда то жаловался на нее...) слева и 15 справа
1-2-3-4 клики мышью:


Результат 13 и 15:


ладно, тут задача как раз не для новичков. кликами до полигона не доберетесь.
Но мы то не из того теста smile3009.gif идем в полигон менеджер, находим там полигон.
Придется открывать там его свойства и вручную задавать.
(я не знаю, кто как задает цепи для полигонов, но я обычно после отрисовки выбираю полигон и какой-нибудь объект, ПО, например,
и через инспектор можно дать полигону цепь как у ПО)

Либо, один из вариантов: по умолчанию снята галочка Remove Dead Copper, после отрисовки делаем UnShelve и только тогда увидим полигон на плате.
Но в этом случае полигон перескакивает на Bottom, и его еще оттуда придется доставать
Вот:


И еще фишка, если полигон Unshelve, то в менеджере полигонов показывается, что цепь не подключена (ля-ля-ля):



В общем, я уже не хочу спрашивать глюк это, ошибка или какая новая фича и будет ли это исправлено, мне пофиг.
Мне интересно одно: Где вы эту дурь берете???? У меня сейчас человек в Китае, надо его попросить привезти, веселей буду смотреть на все это.
Alex Ko
Цитата(Alexey Sabunin @ Nov 27 2014, 10:36) *
По всем вопросам прошу по возможности прикладывать рисунки и файл, где это можно проверить.
Нет проблем:
Нажмите для просмотра прикрепленного файла
Teardrops добавлялись в готовую топологию, без Forced. Виден конфликт с проводниками, с заливкой полигоном тоже где-то конфликтнуло. Старые слёзки работают нормально
Владимир
Цитата(Alex Ko @ Nov 27 2014, 14:45) *

Да, такое есть. На сложных платах бывает в районе десятка.
Конечно не правильно. Но еще правильней подправить топологию, что я и делаю.
Если бы исчислялась сотнями-- завыл бы конечно.

Цитата(peshkoff @ Nov 27 2014, 13:36) *
Значит, первое: убрали возможность постоянной перезаливки полигонов Repour-Always

Жаловались на постоянную перезаливку и потерю времени. Была версия просто был не залит, и если надо было не заливать, тода эти 2 клика.
Начали другие жаловаться. теперь всегда два клика, но выбор перезаливать или нет.
Опять жалобы.
От жалоб никуда не деться.
"Что русскому хорошо, то немцу смерть"
Лично мне нравится неперезалитый вид. Но я молчу.
Цитата
Вот так выглядят процессы рисования
Я конечно знаю многие способы, но такие экзотичные редко использую
Цитата
Либо, один из вариантов: по умолчанию снята галочка Remove Dead Copper, после отрисовки делаем UnShelve и только тогда увидим полигон на плате.

Ну если он не принадлежит никому и убрать мертвое-- то его как-бы и нету, если он перезалит
Alex Ko
Цитата(Владимир @ Nov 27 2014, 15:09) *
Да, такое есть. На сложных платах бывает в районе десятка.
Конечно не правильно. Но еще правильней подправить топологию, что я и делаю.
Если бы исчислялась сотнями-- завыл бы конечно
Платка - простейшая, 3 ошибки.. А править слёзки-регионы - то ещё удовольствие. Так что помещаю в меню Legacy Teardrops, пока Альтиум не подчистит за собой..
Владимир
Цитата(Alex Ko @ Nov 27 2014, 15:31) *
Платка - простейшая, 3 ошибки.. А править слёзки-регионы - то ещё удовольствие. Так что помещаю в меню Legacy Teardrops, пока Альтиум не подчистит за собой..

Так правится не они, о дорожки отодвигаются или центрируются. (как правило центрируются). У меня это только под BGA бывает.
Turnaev Sergey
Цитата(Владимир @ Nov 27 2014, 15:09) *
Жаловались на постоянную перезаливку и потерю времени. Была версия просто был не залит, и если надо было не заливать, тода эти 2 клика.
Начали другие жаловаться. теперь всегда два клика, но выбор перезаливать или нет.
Опять жалобы.

В одной из прошлых версий, эта настройка была, и было удобно. Кому не надо, могли отключить постоянную перезаливку. А сейчас выбора действительно нету. sad.gif
Uree
Цитата(Alexey Sabunin @ Nov 25 2014, 19:32) *
Подтверждаю, ошибка есть! Я обычно выключаю клавишами N>H>A и включаю N>S>A. При описанном выше порядке действительно цепи не перерисовываются. Спасибо за описание - будем исправлять.

p.s. Именно эта ошибка появилась не в 15-й версии.


Слишком глобальное управление, чтобы им пользоваться. Все включить/выключить редко когда нужно. Часто классами, иногда на уровне компонента есть смысл управлять отображением, удобно было бы вживую гасить/включать соединения, но чего нет, того нет...
И да, такое поведение в 14.3.14 уже было. Раньше не скажу, не работал в альтиуме.
Uree
Не выключается настройка Walkaround Obstacles:

Нажмите для просмотра прикрепленного файла

Вхожу в настройки, снимаю птицу, подтверждаю, закрываю.
Открываю - снова установлена. ВТФ???
ClayMan
Я не пойму, в Протеле нет тестировщиков софта? Или они просто не тратят на это время и сразу пуляют продукт на рынок? Ну читаешь это все - какой-то мрак просто, баги появляются даже там, где вроде как и не меняли ничего. Как можно полагаться на такой пакет? Опять же - убрали настройку по полигонам..зачем осознанно лишать пакет гибкости? Ведь настройки для того и вводятся, чтобы угодить привычкам/стилю работы разных людей. Кто придумывает все это, пьяный индус?
Владимир
Цитата(Uree @ Nov 28 2014, 14:09) *
Не выключается настройка Walkaround Obstacles:

Нажмите для просмотра прикрепленного файла

Вхожу в настройки, снимаю птицу, подтверждаю, закрываю.
Открываю - снова установлена. ВТФ???

У вас ниже Walkaround Obstacles стоит в текущей позиции. Выберите отличную от Walkaround Obstacles позицию там
Uree
Спасибо, помогло. Но зачем так делать - одно и то же в двух местах управляется? И в двух ли?..
Владимир
Цитата(Uree @ Nov 28 2014, 17:12) *
Спасибо, помогло. Но зачем так делать - одно и то же в двух местах управляется? И в двух ли?..

первый указывают между какими можно переключаться. Второе-- которое открытое по умолчанию.
Конечно, формально должно было вас обругать и предложить выбрать из оставшихся с галочками.
Uree
Имхо - масло масляное...
Alexey Sabunin
Цитата(peshkoff @ Nov 27 2014, 14:36) *
Прикладываю.
Так, небольшой тест на 10 минут. О полноценной работе само собой разговора то не может идти.
Решил выбрать самое одно из самых больных мест альтиума, уж извините.. Полигоны.
1. Значит, первое: убрали возможность постоянной перезаливки полигонов Repour-Always
Теперь нас каждый раз при прикосновении к полигону будут спрашивать:
Ну а что вы хотели? Вы думали, что вы все знаете?
Я бы предложил еще ввести кнопочку с замочком, которая требует прав администратора, а в будущем еще прикладывать документ от руководства о разрешении перезаливки.
Ну а что, мы же ТУПЫЫЫеее...

2. Ладно, начинаем рисовать.
Вот так выглядят процессы рисования в 13 (блин, а я, нелюдь, когда то жаловался на нее...) слева и 15 справа

3. ладно, тут задача как раз не для новичков. кликами до полигона не доберетесь.
Но мы то не из того теста smile3009.gif идем в полигон менеджер, находим там полигон.
Придется открывать там его свойства и вручную задавать.
(я не знаю, кто как задает цепи для полигонов, но я обычно после отрисовки выбираю полигон и какой-нибудь объект, ПО, например,
и через инспектор можно дать полигону цепь как у ПО)

Либо, один из вариантов: по умолчанию снята галочка Remove Dead Copper, после отрисовки делаем UnShelve и только тогда увидим полигон на плате.

4. Но в этом случае полигон перескакивает на Bottom, и его еще оттуда придется доставать

5. И еще фишка, если полигон Unshelve, то в менеджере полигонов показывается, что цепь не подключена (ля-ля-ля):

В общем, я уже не хочу спрашивать глюк это, ошибка или какая новая фича и будет ли это исправлено, мне пофиг.
Мне интересно одно: Где вы эту дурь берете???? У меня сейчас человек в Китае, надо его попросить привезти, веселей буду смотреть на все это.

Владимир, спасибо подробное описание.
1. Это был небольшой эксперимент. По идее эту опцию должны восстановить в ближайшем обновлении.
2. Наблюдал такое поведение у себя на стадии бета тестирования, потом пропало. Сейчас у себя такое воспроизвести не могу, хотя еще несколько пользователй наблюдали такое поведение. Может удастся заметить какие-то факторы, влияющие на такое поведение (однослойный режим, маска или еще что...)
3. С опцией Remove Dead Copper - понятно, это уже пофиксили
4. Не могу такое воспроизвести, это происходит со всеми полигонами на всех слоях? нельзя ли уточнить шаги? Были ли скопированы настройки программы из предыдущей версии?
5. Уже исправлено (будет в обновлении)


Цитата(Alex Ko @ Nov 27 2014, 15:45) *
Нет проблем:
Teardrops добавлялись в готовую топологию, без Forced. Виден конфликт с проводниками, с заливкой полигоном тоже где-то конфликтнуло. Старые слёзки работают нормально

Также нужен пример файла, хотябы с одним проблемным участком...
Alex Ko
Цитата(Alexey Sabunin @ Dec 2 2014, 00:47) *
Также нужен пример файла, хотябы с одним проблемным участком...

Нет проблем.. Нажмите для просмотра прикрепленного файла
Ошибка в районе X:8 Y:5.5 mm
Иногда Online-проверка не отлавливает, нужна Batch..

А как насчёт переброса в другое окно? Неужели больше ни у кого не проявлялось? Нет карт ATI/AMD?
Я уже потерял надежду, на работу тоже NVidia заказал..
peshkoff
Цитата(Alexey Sabunin @ Dec 2 2014, 00:47) *
Владимир, спасибо подробное описание.
1. Это был небольшой эксперимент. По идее эту опцию должны восстановить в ближайшем обновлении.
2. Наблюдал такое поведение у себя на стадии бета тестирования, потом пропало. Сейчас у себя такое воспроизвести не могу, хотя еще несколько пользователй наблюдали такое поведение. Может удастся заметить какие-то факторы, влияющие на такое поведение (однослойный режим, маска или еще что...)
3. С опцией Remove Dead Copper - понятно, это уже пофиксили
4. Не могу такое воспроизвести, это происходит со всеми полигонами на всех слоях? нельзя ли уточнить шаги? Были ли скопированы настройки программы из предыдущей версии?
5. Уже исправлено (будет в обновлении)



Также нужен пример файла, хотябы с одним проблемным участком...



Да, когда я ставил 15 версию, я попросил скопировать настройки.
В общем снес полностью 15 версию, установил заново и настройки не копировал.

Да, работает получше, полигон виден во время рисования, но исчезает после того, как нарисован, если цепь не была назначена (При старте рисования было указано No Net)
Обычно я рисую так, т.к. цепь замучаешься искать в списке, тем более она не всегда VCC или GND, бывает и промежуточные.
Поэтому сперва я рисую полигон NoNet, а после его выделяю и выбираю площадку, открываю инспектор,
он мне показывает, что выбраны два объекта и цепь разная:

Щелкаем в цепь и он пишет, что выбирает цепь Пада (т.к. у пада выше приоритет)

и после нажатия ентер полигону присваивается цепь пада.
Может кто знает более быстрый способ?

Поэтому я сперва рисую полигон NoNet и по этой причине он не виден после рисования:

если выделить (но нужно сзнать, где он sm.gif ), то он виден:


Кстати, если ему подвигать границы, то у меня высвечивается какая то ошибка и полигон становится видимым sm.gif
Хоть и не залит


Ошибка в п.4, когда полигон рисовался Shelve, видимо действительно перекочевала с настройками из 14-го.
При установке на чистую, не проявляется. Так что вывод - не копируйте настройки.


И еще. Не убирается вертекс на прямом участке? Раньше он исчезал.


С присвоением цепи для полигона все время беда была. Нужно сделать как у региона (можно как опцию)
При рисовании региона, без приглашения дается цепь в зависимости от объектов, на которые он попадает.
При нескольких объектах дает вариант для выбора.
Нужно сделать также для полигона!
bodom83
Не работают чекбоксы в меню Design Ingsight!

В схеме, при наведении мышкой на определенный объект - появляется всплывающее окно с информацией.
После отключения всех пяти пунктов отображения в меню Design Insight, по идее они должны исчезнуть, но не тут то было.
И еще очень раздражает создание скрытой папки Preview на каждый открытый файл. (естественно в предыдущих версиях меню Design Insight корректно работало и эта папка не создавалась)
Alexey Sabunin
Цитата(peshkoff @ Dec 2 2014, 13:01) *
Да, когда я ставил 15 версию, я попросил скопировать настройки.
В общем снес полностью 15 версию, установил заново и настройки не копировал.

Да, работает получше, полигон виден во время рисования,

1. но исчезает после того, как нарисован, если цепь не была назначена (При старте рисования было указано No Net)
Обычно я рисую так, т.к. цепь замучаешься искать в списке, тем более она не всегда VCC или GND, бывает и промежуточные.
Поэтому сперва я рисую полигон NoNet, а после его выделяю и выбираю площадку, открываю инспектор,
он мне показывает, что выбраны два объекта и цепь разная:

Щелкаем в цепь и он пишет, что выбирает цепь Пада (т.к. у пада выше приоритет)
и после нажатия ентер полигону присваивается цепь пада.
Может кто знает более быстрый способ?

Поэтому я сперва рисую полигон NoNet и по этой причине он не виден после рисования:
если выделить (но нужно сзнать, где он sm.gif ), то он виден:

2. Кстати, если ему подвигать границы, то у меня высвечивается какая то ошибка и полигон становится видимым sm.gif
Хоть и не залит
Ошибка в п.4, когда полигон рисовался Shelve, видимо действительно перекочевала с настройками из 14-го.
При установке на чистую, не проявляется.

3. Так что вывод - не копируйте настройки.

4. И еще. Не убирается вертекс на прямом участке? Раньше он исчезал.

5. С присвоением цепи для полигона все время беда была. Нужно сделать как у региона (можно как опцию)
При рисовании региона, без приглашения дается цепь в зависимости от объектов, на которые он попадает.
При нескольких объектах дает вариант для выбора.
Нужно сделать также для полигона!


1. Эта проблема известна, галка Remove Dead Cooper срабатывает, хотя не должна в таком случае, исправили.
2. Это ввели в 14.3, если полигон отредактирован и неперезалит - то он маркируется как Modofied, и отмечается в DRC. Если не актуально - можно это в DRC отключить. Это в будующих релизах будет еще больше использоваться.
3. Это важно! Лучше не копировать настройки из старых версий! Это создает проблемы, когда в старой версии была индивидуальная настройка, а ее убрали в новой версии. Ее значение может привести к неверной работе. Сейчас думаем как такие случаи избежать.
4. Если там был клик, то по идее не убирается. Должен убираться пользователем! Нужно взять вертекс и нажать DEL.
5. Обсуждались мысли как давать имена полигонам, пока к однозначному решению не пришли.

Цитата(bodom83 @ Dec 2 2014, 15:16) *
Не работают чекбоксы в меню Design Ingsight!

В схеме, при наведении мышкой на определенный объект - появляется всплывающее окно с информацией.
После отключения всех пяти пунктов отображения в меню Design Insight, по идее они должны исчезнуть, но не тут то было.
И еще очень раздражает создание скрытой папки Preview на каждый открытый файл. (естественно в предыдущих версиях меню Design Insight корректно работало и эта папка не создавалась)

По идее папка Preview должна быть одна на проект!
С чакбоксами - непонятно, у меня вроде бы работает. Можно рисунок?!
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.
Invision Power Board © 2001-2017 Invision Power Services, Inc.